Customers With Disabilities

    Verizon Business Sites

  • Services  
  • My Verizon  

    Email & Calls

    Check Email

    Verizon Visual 411



    Bill & Payment

    View Bill

    Pay Bill

    Pay Final Bill

    Manage Auto Pay

    Manage Paper Free Billing

    My Services

    Add or Change Services

    Renew or Change Bundle

    Review Account

    Manage My Internet

    Manage My Voice


  • Support  

    Community help





  • Watch FiOS  

    Watch thousands of your favorite TV shows and movies On Demand and Live. Rent or buy your favorites and watch them on any device. Or, check what's on tonight and program your DVR. You can do it all!

    Watch Free TV & Movies



    Rent or Buy

    Set your TV Viewing Experience

  • Trending  

    Check out this personalized, real-time feed featuring the latest content and entertainment from around the Web including new headlines, sports, entertainment and more.






    See what's Trending!

Posts: 3
Registered: ‎06-28-2010
0 Kudos

nook Wi-Fi can't connect to internet

I just got a nook from Barnes and Noble. I can get it to connect to my router. I even see the IP address by logging in to the router's admin console. But the nook can't connect to the internet.


I previously had the same issue with an older PC running Windows 2000, and Verizon support said that Windows 2000 wasn't "officially supported". I was able to get the same PC (exact same hardware) to connect to the internet by running Ubuntu instead of Windows 2000.


I hope that Verizon isn't somehow blocking my nook from connecting.


Any help is appreciated.

Gold Contributor VII
Posts: 5,403
Registered: ‎09-24-2008
0 Kudos

Re: nook Wi-Fi can't connect to internet

#1 What is the brand and model of your router?


#2 What web browser does this Nook use? At least the name would help...



If you are the original poster (OP) and your issue is solved, please remember to click the "Solution?" button so that others can more easily find it. If anyone has been helpful to you, please show your appreciation by clicking the "Kudos" button.


All Star
Posts: 1,729
Registered: ‎11-10-2009
Device: Chromecast tv phone
Plan: Digital Voice, 75/35
Location: Westford MA

Re: nook Wi-Fi can't connect to internet

What version software is your nook running?

You may want to make sure it's at the latest version which I believ is 1.4



Posts: 3
Registered: ‎06-28-2010
0 Kudos

Re: nook Wi-Fi can't connect to internet

I finally got it to work. I don't know how, but all I did was disconnect from the router and reconnect. I then used the web browser on the nook to connect to and it worked.

Posts: 2
Registered: ‎11-28-2010
0 Kudos

NOOK color connects using WPA2/AES Re: nook Wi-Fi can't connect to internet


I just got my NOOK Color and it connects to my FIOS WIFI Action Tec MI424WR using WPA2 and AES.


At first it would not connect in trying to register (it acted like it connected but the continue button remained grayed out).   I remembered that a long time ago I had changed the router to only accept one wire-less connection per only one MAC address.  Since I forgot my password, I reset the router to factory defaults... then set the new key.  Hope that helps.


The other option to AES is TKIP, but I did not try it.   I vaguely remember a couple of years ago that my toshiba Vista laptop

had trouble connecting and I had to use TKIP so I may have to try it.

Gold Contributor VII
Posts: 5,960
Registered: ‎12-15-2010

Re: NOOK color connects using WPA2/AES Re: nook Wi-Fi can't connect to internet

Don't bother with TKIP if you're using WPA2. Defeats the purpose of it. AES is better hands down.
The first to bring me 1Gbps Fiber for $30/m wins!
Posts: 2
Registered: ‎01-06-2012
0 Kudos

Re: nook Wi-Fi can't connect to internet

There is a problem with nook software version 1.1.0 and the verizon actiontec rev F router.

Many B and N customers are having this problem.

I don't know who is going to fix this problem which is a dynamic vs static connection issue.

Platinum Contributor I
Posts: 5,721
Registered: ‎07-22-2009
0 Kudos

Re: nook Wi-Fi can't connect to internet

Posts: 1
Registered: ‎05-16-2012
0 Kudos

Actiontec MI424WR Rev. F router and Nook Color don't play well together

I have the loathesome Actiontec MI424WR Rev. F router and a new Nook Color loaded with 1.2 software. No internet connection on the Nook. Notably, I suffer no issues whatsoever with any of the other nine devices on my home network using WPA2 PSK, all of which like the NC are assigned static i.p. addresses thereon (makes no difference, though--the NC will not fully connect regardless).


Took the NC to a local public wireless hotspot to register it with BN, thinking that might somehow make it compliant and happy upon our return home (registering somehow helped with an older simple touch we have). No such luck. The procedure linked to by Hubrisnxs as an apparent solution in early January has not worked, either, although it seems to end a thread or three on the subject as if it is the final definitive word on it. I certainly hope not, because for me that represents a dead end.


Any and all help appreciated.


My Verizon

Support Tools

Watch FiOS


  • Visual 411