Customers With Disabilities
  • Shop

    Order Services

    See All Plans & Bundles

    Special Deals



    Current Customers

    Add or Change Services

    Renew or Change Bundle

    Find out which Verizon services are available at your address.

  • My Verizon

    Email & Calls

    Check Email

    Verizon Visual 411



    Bill & Payment

    View Bill

    Pay Final Bill

    Manage Auto Pay

    Manage Paper Free Billing

    My Services

    Add or Change Services

    Suspend My Service

    Renew or Change Bundle

    Review Account

    Manage My Internet

    Manage My Voice


    My Rewards+

    Manage My Rewards+

    Refer a Friend




  • Support

    Community help





    Search Support

    Connect with us

    Verizon on Facebook Verizon on Twitter Verizon on Google Plus Verizon on YouTube

  • Watch Fios

    Watch thousands of your favorite TV shows and movies On Demand and Live. Rent or buy your favorites
    and watch them on any device. Or, check what's on tonight and program your DVR. You can do it all!

    Watch Free TV & Movies



    Rent or Buy

    Set your TV Viewing Experience

  • Trending

    Check out this personalized, real-time feed featuring the latest content and entertainment from around the Web including new headlines, sports, entertainment and more.

    News & Lifestyle

    Have a laugh, learn a trick and discover the awesomeness of Fios. Explore Fios Lounge today.

    Fios Lounge





Posts: 5
Registered: ‎01-27-2012
0 Kudos
Accepted Solution

MI424WR-GEN3i (Rev. I) no wireless "Performance Mode 802.11n device only" setting.

  Hi, I have a MI424WR-GEN3I (Hardware Version I) router with firmware version 40.19.22.  Per the routers user manual (MI424WR, rev.I) it is capable of reaching 160Mbps 802.11n wireless speeds.  But when I go into the router's "802.11b/g/n setup menu I see only two options: 1) Compatibility (802.11b,g, and n devices)  and 2) Legacy (only 802.11b and g devices).  I do not have the "Performance (only 802.11n devices) option to select, as per the user manual.  How do I get the router to show the "Performance, 802.11n only device option so that I can select it?  I must be missing something in the routers setup menu but just can't figure it out.  Any help will be greatly appreciated.  Thank you for your time and assistance.

Silver Contributor V
Silver Contributor V
Posts: 1,758
Registered: ‎05-22-2010
0 Kudos

Re: MI424WR-GEN3i (Rev. I) no wireless "Performance Mode 802.11n device only" setting.

[ Edited ]

Not sure why it doesn't show on yours.  Shows on mine

Wireless Settings

Advanced Security Settings

80211b/g/n mode


I am shown three options in the drop down although only two show up in text descriptions (not the drop down)


Compatibiliy mode

Legacy mode

Perfomance mode.


802.11 Mode


Access to the Router's network can be restricted to wireless devices using either 802.11b/g (11Mbps/54Mbps) or 802.11n (130 Mbps) wireless devices. Select the option that best applies to your wireless network. Then click Apply button to save your settings.

'Compatibility Mode' to support 802.11bg & 802.11n.
'Legacy Mode' to support only 802.11bg.

 802.11 Mode:Compatibility Mode(802.11b/g/n)Legacy Mode(802.11b/g)Performance Mode(802.11n)


Posts: 5
Registered: ‎01-27-2012

Re: MI424WR-GEN3i (Rev. I) no wireless "Performance Mode 802.11n device only" setting.

             > > SOLVED < <


Ok, figured it out!  In the Verizon router setup under Wireless Settings >  Advanced Security Settings > Level 1:  WPA2 >  Encryption Algorithm ; I had an option of TKIP/AES selected.  I changed that to AES  only and then "Performance Mode(802.11N)" showed up in the selection box for 802.11 Mode options.  Thanks for your input and help.


My Verizon

  • Check Email
  • Add or Change Services
  • Suspend My Service
  • Renew Your Contract
  • Manage Services
  • Announcements

Support Tools

Watch Fios


  • Visual 411