×

Switch Account

Certificate Error, Router home page hacked? (192.168.1.1)

Certificate Error, Router home page hacked? (192.168.1.1)

SOLVED
Reply
Contributor skypickle
Contributor
Posts: 5
Registered: ‎04-04-2019
Message 41 of 66
(6,975 Views)

Until recently, I could point my browser to the verizon fios router ip and log in. I'd get a warning about the self signed certificate, click ok and there i was. However now, the behavior is different. I get a page that says this:

~~~~~~~~~~~~~~~~~~~
Verizon takes your privacy and internet security seriously. To better ensure security, Your router is automatically being redirected to »myfiosgateway.com.

The redirected site is protected with a self-signed certificate, and your internet browser will prompt you with a security warning to accept the router's self-signed certificate before proceeding. This is a standard prompt for any self-signed certificate to help ensure the security of your internet connection.
~~~~~~~~~~~~~~~~~~~

Then I get the usual self signed certificate warning that says this:

~~~~~~~~~~~~~~~~~~~
Attackers might be trying to steal your information from 192.168.1.1 (for example, passwords, messages, or credit cards). Learn more
NET::ERR_CERT_COMMON_NAME_INVALID

Help improve Safe Browsing by sending some system information and page content to Google. Privacy policy

I click on the advanced button and then the usual warning appears below it:
This server could not prove that it is 192.168.1.1; its security certificate does not specify Subject Alternative Names. This may be caused by a misconfiguration or an attacker intercepting your connection.

Proceed to 192.168.1.1 (unsafe)
~~~~~~~~~~~~~~~~~~~

I click on the proceed button and I am back at the same page after a brief flash of this

~~~~~~~~~~~~~~~~~~~
Verizon takes your privacy and internet security seriously. To better ensure security, Your router is automatically being redirected to »myfiosgateway.com.
~~~~~~~~~~~~~~~~~~~

I have no problem logging in to the router from a mac!
This occurs on two separate machines (windows 7 pro and windows 10 pro) directly connected to the router by ether net. I dont know why the router is stuck in an infinite loop for windows only since the mac is on the same network. DNS server for all machines is the same in the adapter settings.
What's going on?!

Contributor skypickle
Contributor
Posts: 5
Registered: ‎04-04-2019
Message 42 of 66
(6,969 Views)

I had to use a mac. ALL windows OSes get stuck in this loop. I think Verizon wants us to log in to our router through THEIR network. I guess they can FORCE us to do this as a way of showing US THEY OWN THE ROUTER IN OUR OWN HOME!

 

So even though I reset the router to default, it still locks me out. My solution was to add MY OWN router between the verizon box and my network. The idea that they can snoop my LAN without my consent is ludicrous.

Highlighted
Contributor AlbanyFSC1
Contributor
Posts: 1
Registered: ‎04-06-2019
Message 43 of 66
(6,895 Views)

I am not by any means a network professional, but i may be able to weigh in here, and feel free to correct me if i am wrong. 

 

In the past, the router was accessible through HTTP, which did not require a security certificate, therefore no security warning. It is now forcing a redirect to HTTPS, and on the page advising of the change it warns you there will be a security warning. Now, i don't know if this is being done for customers security, or for compliancy, but changing to HTTPS is happening everywhere. 

 

Now, when you go to your banks website, you are accessing a company that is using HTTPS and has a Trusted CA Certification that they pay for. It means its recognized as a secure site. 

 

Since you are not accessing a publicly accessed website when you are logging into your router, you are visiting a private local IP address of 192.168.1.1 (an IP which absolutely cannot obtain a trusted CA certification, because its a private local IP address) it has no recourse but to issue a self-signed certificate. Your browser, when using HTTPS, by design will throw up a security warning that the site you are trying to reach is using a self-signed certificate. It's basically warning you "Hey, User...make sure you know what you are connecting to on the other end of this IP you are trying to reach". Since you know its a local IP, not accessible on the web, and its pointing to the router in your home, you know it is ok to proceed. 

 

Your browser will do the SAME THING if you were trying to visit a malicious IP address on the web using HTTPS, and since that website may be malicious its not issuing a Trusted CA certification, but a self-signed certificate. Browser, doing what browsers do, says the same thing. "Hey, User...make sure you know what you are connecting to on the other end of this IP you are trying to reach." But in this case, its not your local private IP that points to your router. So, your browser is working as intended to protect you. 

 

Verizon, in trying to be more compliant and more secure for their customers, is trying to improve your security by making the router access via HTTPS. The change to HTTPS obviously has some caveats that will trigger some tech support calls, but i assure you your browser is doing as its programmed to do, and you are not in danger of being eaten by a computer virus or a hacker by accepting the self-signed certificate issued by your router. 

 

Anyone saying that Verizon is being cheap and not paying for a trusted CA certification may not but fully grasping how those SSL certs work. You can buy one yourself if you like...if you have a public IP address and domain. You CAN NOT get one for a private IP of 192.168.1.1 which is what your browser is trying to access. 

 

Once again, if i am wrong or have missed anything, please respond. I am comfortable with ciriticism, and would love to know where i steered awry. 

Administrator Administrator
Administrator
Posts: 1,035
Registered: ‎12-09-2014
Message 44 of 66
(6,808 Views)

This has been retested by our router testing team and they are not seeing any issues with this on IE, Edge or FireFox 66. Certificates are being imported or the exceptions are being allowed, depending on the browser. The only recommendation the team has provided is to ensure the cookies are being cleared. It could also be the Security Level the browser is set to for visiting sites, IE 11 uses zones for this that can be managed and may be set higher than default and could cause issues.

We apologize for this inconvenience.

 



Nilsa
Community Manager

Contributor RichyBroke
Contributor
Posts: 1
Registered: ‎04-09-2019
Message 45 of 66
(6,767 Views)

Hi,

 

I just realized that I have the same issue using any browser or computer. If most people have an issue with the GreenWave Systems certificate than whatever is making it work for your in-house team is not working in our homes.

I know Verizon just released an update to fix a certain vulnerability so it might be related to it.

Please look into the matter more thorougly.

 

Thank you,

Richard

Contributor will822
Contributor
Posts: 1
Registered: ‎04-09-2019
Message 46 of 66
(6,751 Views)

Your team needs to retest again. The fact that so many are reporting issues makes your statement that there are no problems false and incorrect.

Contributor jnv11
Contributor
Posts: 3
Registered: ‎03-30-2019
Message 47 of 66
(6,734 Views)

Now we know why Verizon is now forced to force HTTPS only logins. It is using HTTPS to block a replay attack. See this SecurityWeek article for why Verizon now is forced to disallow HTTP logins.

Administrator Administrator
Administrator
Posts: 1,035
Registered: ‎12-09-2014
Message 48 of 66
(6,756 Views)

I apologize that the information provided by our internal team was not helpful. I have referred this to them again for further investigation and testing. I'm providing information from our product and testing teams and will continue to do so as I obtain it. 

 

For your information, there was also a security fix which changed our default login page from an HTTP address to an HTTPS address on our last release. When visiting the previously used HTTP address there is new verbiage there to inform customers of the change and a redirect to the HTTPS address. When a customer clicks that link they will also get a certificate warning from their browser since the HTTPS is being secured by a self-signed certificate. Once the warning is accepted the warning will continue to the HTTPS site where you will be able to login and manage your devices as usual.

 

Attached is the flow of this experience for your reference:

 

Login Screen Update.JPGLogin Screen Update 2.JPGLogin Screen Update 3.JPGLogin Screen Update 4.JPG

I will provide an update once I hear back from the team. 

 

Thank you for your patience. We sincerely apologize for this inconvenience. 

 



Nilsa
Community Manager

Contributor JetFixxxer
Contributor
Posts: 2
Registered: ‎04-20-2019
Message 49 of 66
(6,318 Views)

Doesn't go past the warning page.  I hit proceed in chrome and advance on FF it just loops back to the warning page.

Contributor Akiro
Contributor
Posts: 2
Registered: ‎04-22-2019
Message 50 of 66
(6,218 Views)

Same for me as well no matter what browser I use

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.