Switch Account


Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-27-2012
Message 1 of 6

Todyay, I received a new MI424WR Rev I router to fix a data corruption problem that I was having.  Revision I has WPA/WPA2 security capability.  I can connect my Sirius/XM internet radio when the router is set to WPA or WPA2, but I can't connect my DRIOD 4 Android phone.  The DROID can see the network.  But it keeps telling me that the password is incorrcect.  I've tried both the default password and I've tried entering my own password.  Both units work if I change the security to WEP.


I know that the phone works with WPA/WPA2 because I have good connections to the network in my office and at a friend's house, which are both WPA2.  I've tried turning the firewall off on my PC, in case that would help, but it didn't (no surprise, I was fishing).


Does anyone have any other suggestions?

Platinum Contributor III
Platinum Contributor III
Posts: 5,881
Registered: ‎07-22-2009
Message 2 of 6

I had that problem with an IPAD, and ODDLY enough, after everything I did, it turned out that it was the wireless channel.  I Am not sure that will help you, but you can give it a try.     open a browser, and go to


user name is admin.  and the password is most likely the serial number found on the service tag of your VZ router unless you changed it. Once you login succesfully, go to the top and hit wireless, then on the left basic security.   then go to option 3 which is channel  1, 6 and 11 and are the only channels you should try.


So it will likely be set to auto, change it to 11 and put the check for keep settings even after reboot (Directly under the channel) and then hit apply.  after you hit apply,  test your connection out, if you notice a difference, leave it like that until the problem happens again, and if it happens again, go back into the router, and try channel 6,     test it out.  and then finally 1 if the first two don't work.


Also take a look at page 2 of Actiontec's Wireless PDF File.  It gives you some idea's with regards to position and orientation of where the router sits and how it can best be positioned for maximum coverage.



Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-27-2012
Message 3 of 6

Thank you.  But that didn't work for me.  I tried all 2 channels with both WPA & WPA2, to no avail.  I don't believe that it's a connection issue.  I'm trying this 5 feet from the router and the phone is rating the reception as "excellent".


thanks again for the suggestion.

Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,413
Registered: ‎12-15-2010
Message 4 of 6

As the Rev. I is Wireless N you'll be needing to set the security to "WPA2-AES PSK" encryption, not mixed WPA/WPA2, and with a 3600 second Group Key Rotation (this is more of an advanced Wireless setting, but it should be there in the ActionTec. MAC address filtering should be off, and the Wireless N mode should be set to either Compatibility or Performance mode. Also, as mentioned above which I'm sure you already tried, auto channel selection absolutely must be off. That bugs a bunch of things out.


Failing that try rolling the Rev. I back to B/G mode to see if the Droid will connect. If that works we'll go from there.

Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-27-2012
Message 5 of 6

My problem was case.  The password uses upper case letters.  When I typed the password into the DROID, I was using lower case letters.  When I first attempted to enter the password, I hit the Caps Lock key and still got lower case letters.  So, I assumed that case didn't matter.  That opinion was compoundeb by the fact that when I entered the password into my Sirius/XM Internet Radio, I only had the option of entering lower case letters and it worked.  Also, when I changed to WEP, I entered the password in lower case letters, even though it was supposed to be upper case, and that worked as well.


Just for the hell of it, rather than pressing Cap Lock, I tried the Shift Key, which allowed me to enter upper case letters.


Once I did, the password was accepted.


Thanks for everyone's help and hopefully, someone else who has the same problem finds this thread and this will help them.

Silver Contributor I
Silver Contributor I
Posts: 218
Registered: ‎07-28-2011
Message 6 of 6

I was going to write that yesterday but got distracted by work 😞 .


It seems that vendors tend to implement the interpretation of wireless keys differently depending on their mood.  And they don't document it very well.  With passphrases, case is important.


With something like WEP, both case and length can be important.  That is, a key of X characters might be interpreted as a Hex string or an ASCII string depending on length and/or Upper/lower case.


Sorry I didn't suggest this to you sooner.


How-To Videos
The following videos were produced by users like you!
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.

Browse Categories

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.