quick menu

G1100 2.4 wifi slow or impossible to connect

G1100 2.4 wifi slow or impossible to connect

SOLVED
Reply
Contributor SADresser
Contributor
Posts: 7
Registered: ‎11-17-2018
Message 1 of 3
(268 Views)

I've had a problem develop with my G1100 in the last 2-3 weeks which has essentially rendered the 2.4ghz wifi interface unusable. 5ghz wifi and ethernet all working fine, I can run a speedtest over 5ghz and ethernet with no LAN or WAN performance or connectivity issues. Here's the weird thing, I also have a guest wifi that also works fine and it appears to share the same 2.4ghz physical interface as the 2.4ghz non-guest network. For example, I can run a simple test that goes like this:

- Disconnect all 2.4ghz clients from both the 2.4ghz Non-Guest and Guest networks
- Connect a single Mac to the Guest network
- Ping the 192.168.1.1 router interface
- Pings run consistent at about 15-40ms (similar to my 5ghz interface). I can also run a speedtest and the results look good - 75/75
- Switch the same Mac to the 2.4ghz Non-Guest wifi
- Ping the 192.168.1.1 router interface
- Pings run at a minimum in the 100ms range but frequently jump to 1000-2000ms and average around 400-500ms! If I log into the router it is extremely slow. Other devices like an iPhone or Nest thermostat sometimes can't even connect to the 2.4ghz wifi, they get prompted for the wifi password, and/or fail to connect.

I'm on my 3rd G1100 after spending hours on the phone with tech support to no avail so I don't think it is a hardware problem (at least specific to a particular router). The G1100 I'm using now is hardware 1.04 which is the latest. Firmware is 02.01.00.05. Given that the Guest and Non-Guest wifi's run on the same 2.4ghz channel I don't believe this is an air interface issue either since Guest seems to run fine.

I've tried changing mode settings on the 2.4ghz network, disable/enable the interface, master reset/config reloaded but nothing seems to bring 2.4ghz out of its funk. The other other suspicious thing I notice is that the receive errors on the 2.4ghz interface steadily climb, only on the 2.4ghz interface, even when there is no 2.4ghz client connected to the network.

I see a number other threads on this group where people have had similar issues but no resolution.

The frustrating thing is that this was working fine up until about 2-3 weeks ago which makes me suspicious that it might have something to do with the Home Network Protection (McAfee) that Verizon released back in Nov/Dec. I've disabled this but I've also had other issues with this new firewall in the router preventing access to certain servers used by Adobe Lightroom. Wondering if it might be playing a role here.

I'm to the point now where I'm suspecting some type of bug or throttling issue in the router.

Suggestions (other than installing a 3rd party router) of other things I could try to diagnose the issue?

2 REPLIES
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,292
Registered: ‎12-15-2010
Message 2 of 3
(208 Views)

I believe we were troubleshooting this issue over at this DSLReports thread: https://www.dslreports.com/forum/r32276717-Router-G1100-2-4-wifi-slow-or-impossible-to-connect

 

Looks like this may be getting caused by Broadcast traffic on the network. DId you have any luck ruling out the Sonos or a specific device that was causing problems? Anything a packet capture from the Mac show?

Contributor SADresser
Contributor
Posts: 7
Registered: ‎11-17-2018
Message 3 of 3
(143 Views)

Yes, I was thanks for your help there.   Here's the same summary of my findings that I posted on that group - hopefully it will help someone here:

 

One more update to this thread since the final resolution was probably not related to my Sonos (although it may have played a role). Several hours after my last post the symptoms returned again so I loaded up wireshark and started poking around. What I eventually figured out was an iMac on my network was sending out a bunch of unsolicited mDNS responses, both IPv4 and IPv6. This computer is on my 5ghz wifi but since the mDNS responses are sent to a multicast address they were getting sent out everywhere and must have flooded the 2.4ghz network. As soon as I rebooted the Mac everything cleared up and wireshark showed that there were many fewer packets on the network. I'm still not sure why the mac running 10.14 was doing this but I did get an error after rebooting indicating that my Time Machine backups (to a local network NAS) had not been working for 14 days which is about the time I had the problems. My best guess is something happened to the NAS or the network around that time and it caused the Mac to get into a bad state. Hopefully this will be helpful for someone else.

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.

My Fios App
Fios TV App
Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.
 

My Verizon

  • Add or Change Plan
  • Suspend My Service
  • Apps

Support

Watch Fios