×

Switch Account

G3100 DHCP server problems

Reply
Highlighted
Contributor
Contributor
Posts: 7
Registered: ‎07-16-2019

G3100 DHCP server problems

Message 1 of 2
(431 Views)

I have discovered a bug where if you use spaces in device names, eventually the G3100 DHCP server will stop leasing out IPs, probably due to it crashing or something. I specifically noticed this when setting static leases, but I believe it affects all lease types. The G3100 web interface does not allow you to use spaces or illegal characters in device names, but the FiOS app does...

I had renamed a device using the FiOS app and included a space. Later, I set a static DHCP reservation for the device. Soon after, I noticed that it didn't work anymore. I changed it back to dynamic, but it still didn't get an IP. Then I rebooted the router and then all devices could not get an IP. It wasn't until I went it and removed the spaces from the device names that the router began leasing IPs again. I could tell that the router had stopped leasing IPs by checking the LAN DHCP log, which showed no activity if devices were named improperly.

Now with devices named properly, I am able to statically and dynamically assign IPs without issue.

Firmware version is 1.3.6.27
Hardware version: 1103

1 REPLY 1
Highlighted
Contributor
Contributor
Posts: 1
Registered: ‎07-03-2020

Re: G3100 DHCP server problems

Message 2 of 2
(220 Views)

Thank you!! A panic was starting to set in after I couldn't figure out why the router had stopped assigning DHCP addresses...sure enough, removing the space from one of my device names in the router's interface seems to have fixed it. Even more insidious than what you described, I never used the Fios app: the device in question had evidently given itself (or had automatically assigned) a name with a space in it, and after setting that device to have a static IP, the web interface allowed me to keep that name. It seems this is the default behavior if 1) the device name has spaces in it by default AND 2) I don't attempt to edit the device name after assigning it a static IP, i.e., I never clicked in the 'Host name' box to edit the device's name.

I set all my static IPs on the router side. In order to get back into the router interface, I just set my Windows network interface configuration to assign itself a static IP, so it needn't get the IP from the router's DHCP server. Then, entered the router interface (at 192.168.1.1), edited the problematic device name, confirmed there were no other problematic device names, and changed my Windows configuration back. Very glad you noticed this -- hoping the software devs at Verizon see it.

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Covid19


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.