Accessibility Resource Center Skip to main content
Get it fast with In-store & curbside pickup or same day delivery.

G3100 WiFi issues

Posts: 2
Registered: ‎07-08-2020

G3100 WiFi issues

Message 1 of 5

I have the 3100 with gigabit speeds.  If I connect with a Ethernet cable to laptop I have no issues with full speed testing.  This issues I’m having is with the WiFi. I get terrible  download speeds. 200 down maybe 500 up with a device that supports Wi-Fi ax. I know the router with its current firmware doesn’t support ax. But here is where the real issues lie. I tried disabling the son and connecting to just the 5g side same slow speed issues.  If I disabled the QOS i was unable to connect to the 5g band. I could connect to the 2.4 and only get 10 up and down. I got them to send me a replacement router. With the same problem except I could connect to the 5g but I only get 10 up and down. Is there a way to force the router to get the 1.5.x.x firmware instead of the that it is running.  This is some kind of firmware issue with the router.  I’ve tried multiple devices and always the same issue. I’ve rebooted the router done factory resets. It doesn’t matter. The second I disable QOS I get sloooow speeds if I leave it on I get very spotty and slower speeds than I should be getting   Lol please help

Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 6,034
Registered: ‎09-24-2008

Re: G3100 WiFi issues

Message 2 of 5

#1 For the Wi-Fi issue points to


#2 For the firmware, no you can not force the update the firmware. Not to change my mind, perhaps ask the ISP support person to do it for you.

If you are the original poster (OP) and your issue is solved, please remember to click the "Solution?" button so that others can more easily find it. If anyone has been helpful to you, please show your appreciation by clicking the "Kudos" button.


Posts: 2
Registered: ‎07-08-2020

Re: G3100 WiFi issues

Message 3 of 5

It’s not a range issue I can be on top of the router and get the same speeds. It also isn’t an interference issue and im not competing with any other strong WiFi signals around me.  I’ve spoken with everyone at Verizon and with the router manufacturer.  It has something to do with the way the router is handling the WiFi data.  They don’t have a fix for it. Also the WiFi 6 speeds they tout for this router are disabled. It only works at WiFi 5 speeds and they don’t know when they are going to enable WiFi 6. Which is disturbing due to the fact they charge more for the router when the older quantum gateway has faster WiFi 5 speeds than the new router.  I’m probably going to go back to the free router they have with a gigabit connection and bypass this hunk of garbage. With my own WiFi 6 router.  
verizons customer support has been useless and it takes hours/ the next day to get anyone on the phone. I know we are dealing with COVID now but it is totally unacceptable in a day when tech support can be done from the home.  I’ve been with Verizon for over ten years and this is the first time I’m considering going to Comcast. I’ve been charged a 175 dollar gigabit upgrade fee when I didn’t need a new ont or a service call due to me upgrading the connection from MOCA TO Ethernet on the ont and running the cable.  They guy came to the house and was like you didn’t need me to come out. So I’m 1 very unhappy customer.  A router that doesn’t work properly and a fee for service I didn’t need. 

Posts: 2
Registered: ‎09-16-2020

Similar issues

Message 4 of 5

I upgraded to the 3100 after my 1100 radios started to cause issues. It was pretty old as well.  I've ended up turning off the radios on the 3100 and using an actiontec for 2.4 and linksys for 5ghz, as the 3100 constantly drops the wifi, literally dozens of times a day. Considering the $300 price tag, I am not happy. 

Silver Contributor V Silver Contributor V
Silver Contributor V
Posts: 605
Registered: ‎09-06-2020

Re: Similar issues

Message 5 of 5

I believe this is a known issue of G3100. It is a possibility that some wireless devices defaults to use 802.11ac at 5GHz, when there is a packet sent via 802.11ax, the devices are confused and disconnected.


I need to check the IEEE WLAN framing to be sure.

How-To Videos
The following videos were produced by users like you!
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.

Browse Categories

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.