×

Switch Account

Horrible Upload/Download Speeds

Horrible Upload/Download Speeds

Reply
Contributor Bradley
Contributor
Posts: 1
Registered: ‎11-10-2019
Message 1 of 1
(105 Views)

New laptop less than a year old. Since being on Fios here at a new residence, my internet speed has been horrible. I am 8 feet from my router. I am using an AVG Secure Browser Without warning, 6-10 times per day, NEW webpages will display "Page Not Responding" message and a choice to Wait or End it. It NEVER fixes itself. I can toot around just fine in webpages that are already open. Then after awhile they stop working. I can open a webpage instantly in Microsoft Edge no problem. I have run the Troubeshooter on my Network Adapter with no issues. I've Run Compatibility tests with AVG and it says there are no issues.

 

The ONLY fix is to do Power down a forced shut off and restart. That gives me a couple of hours before it starts all over again. If it matters, I do occasionally see where the laptop does lose Internet Connectivity during the day yet my phone still works fine in the house. Also, I used to see Awww Snap when trying to load new web pages but that has been replaced by Page Not Responsive messages. Also, Facebook wil suddenly lose the ability to display pictures when the probem starts.

But this right here is abysmal and really makes no sense. 

Anybody have any ideas? TIA

Speed test

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.