Customers With Disabilities
quick menu

Itunes Sharing not working over wireless

Itunes Sharing not working over wireless

Message 11 of 30

i have this same problem with actiontec, but not with sharing - with airplay not working.


Just like you, if i hardwire to the actiontec, i can airplay and the icon shows.  When i use wireless, it does not show the icon and it does not work.


I tried your SSID trick, but not modifying the WPA2 key.  I stil use WEP, currently.  Any idea what is differences there are between wired and wireless from the same actiontec router?

Message 12 of 30

I have the exact same problem, but not with iTunes but media center sharing DLNA / microsoft. I'm trying to access and play my library from wired computer on a PS3 (wireless) ... the PS3 (wireless) can see my laptops (wireless) but not my wired desktop computer. When I move a laptop from wireless to wired, the PS3 can no longer find that laptop either.


I have done some packet sniffing on both wired and wireless computers when PS3 is searching, and found that the wired connections are not seeing the broadcast packets from the wireless segment. The wireless computers see (and respond to) these broadcast SSDP packets.


1. this is with the Actiontec router MI424WR rev I that Verizon sends everybody...

2. all firewalls are off (triple-checked) take my word for it

3. wireless security is WPA2

4. all computers are on the same subnet and have the proper netmask, etc... I can ping from any box to any other regardless of physical connection - the issue seems to be these broadcast packets.

5. I have contacted Actiontec and they said they don't know what is wrong but that is not excpected behavior - they suggest I open a ticket with Verizon engineers so they can investigate...


How do I open a ticket with Verizon engineering? I'm loathe to dial into the normal tech support with this problem as they likely won't know what I'm talking about. Will suggest I reboot everything (again..) ... you know?


Anyway.. any ideas ?



Message 13 of 30

It is the actiontec router.


I did get it to work reliably ONE way, which WILL NOT suffice long term but here is what works:

My Network->Network Connections

From there, the first one on my list is Network (Home/Office), with sub networks showing for Ethernet (the hardwire switch) Wireless, and Coax.  At the parent level of Network (Home/Office), if I modify the settings and change the property 'Network' to 'Broadband', the iTunes airplay instantly shows up in my wireless connected macbook.  I can then airplay to my wired AVR...


SIDE EFFECT: I get no WAN connection within this network any longer.  So, it CAN work, but something to do with the various Network settings doesn't let it work while connecting to internet...

Id like to resolve this since if I get an AppleTV, I will have the same issue since its going to be hardwired...


SIDENOTE: When I hardwire my laptop I can airplay to the airplay device on the same hardware switch in the actiontec...


Message 14 of 30

OK I have this working reliably, now.  AND with still being able to hit outside my LAN Smiley Happy


If you go to Advanced (Accept the warning) and go to the IGMP Proxy menu and disable IGMP Proxy.


This magically makes it work!  I still haven't read up on what the IGMP setting does, but it is a proxy, which obviously interfereres in this  case with AIRPLAY udp messages being broadcast and received.  Hopefully it doesn't adversely affect other devices on my network, but I can cross that bridge then.

Message 15 of 30

Thank you Swizzchard!


I've been looking everywhere for the setting that's blocking the multicast packets... I did a little reading on the IGMP proxy, and it's clear as mud... as are all of the settings in the MI424WR below ENABLE/DISABLE lol... there's enough settings on IGMP proxy in there to impress a cisco engineer... useless for me, tho.


thanks again!

Message 16 of 30

Swizzchard above nailed it.  The IGMP Proxy set to disabled solves this problem.

Message 17 of 30

Man, I've been trying to figure this out for days.  Finally stumbled on this message chain.  It works.  Thanks.

Message 18 of 30

great solution.  Worked for me. Disabling the IGMP Proxy was the fix.  Kudos to swisschard. This fixed both my Iphone synch issue and my Apple TV homesharing problem.

Message 19 of 30

THANK YOU.  I have been working on this issue for days.  Reset router, reconfigured my entire network, rebuilt my PC and wiped my iPhones and iPad and nothing until I stumbled on to this.  I practically cried when this change Worked.

Message 20 of 30

Thanks for the tip! For me it only go me half-way there, I then had to then manually allow IGMP on all my devices. Kind of annoying extra step, would love to know if there's a way to automatically enable IGMP for all devices. For the record I have the MI424WR gen/rev 2.


After disabling IGMP Proxy I was finally able to see my AirPlay device but it would just not play anything when I connected.


In Advanced Settings/IGMP Proxy/Host Multicast Filtering, I had to click the action link on for all my IP addresses and manually enable IGMP. Once I did this everything worked perfectly.


Thanks swizzchard, this had been plauging me for days!




My Rewards+
Start earning points Enrolling in My Rewards+ is quick, free and easy

Refer A Friend
Refer friends to the Verizon Fios Family, and earn 10,000 My Rewards+ points
Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.

My Verizon

  • Check Email
  • Add or Change Services
  • Suspend My Service
  • Manage Services
  • Apps


Watch Fios