×

Switch Account

Problem connecting Ubuntu to Fios

Problem connecting Ubuntu to Fios

Reply
Contributor rkilpatrickii
Contributor
Posts: 2
Registered: ‎01-11-2014
Message 1 of 3
(1,197 Views)

I love my Surface Pro 2 but it is getting old, so about 4 months ago I installed Ubuntu. It has been ten year since I used Red Hat and SuSE so it has been a ruff ride, but I'm going to go ahead and get rid of my other OS completely if all goes well with installing the software I have to have for school in VM. I sat down at my computer today and the Internet did not work so I ran some test and all of the devices in the house are working great and I have very fast upload and download speeds.

Now the Internet has always been slow on my Surface Pro up until I had to take a business trip a few weeks ago. When I got to my barracks I realized that my wireless only worked for a few minutes. After a lot of trial and error I finally figured it out and I was up and running again.

Now I can connect to the Internet by connecting an Apple device or threw WiFi other than what is running in my house. I have Fios and I can connect to the router threw Ethernet cable and WiFi but I can't connect to the Internet. At first I thought it was my computer so I spent several hours looking for answers but I can't find a step-by-step that gets me up and running yet. I know that this is a common problem because I found a lot of post asking for the same help. Some older post that deal with the same problem have been solved but I couldn't figure out how to apply them to Ubuntu 15.10. I am also starting to think that I might be gong at this in the wrong way. When I go into the router and look at the firewall I see a long list of events from today that have been blocked, so I know that the router's firewall is blocking my Unbutu. I have never messed with a router firewall before so I googled this too and I still could not figure out how to get threw to the Internet.

I never use the wireless in my house on this device, so if someone could help with the Ethernet that would be great.

 

I have found a problem, eth0 has no IP adres, but only when I am trying to connect to Fios (as I type this I know it makes no since.) I have pics but but I can't get them to upload.

 

 

 

 

2 REPLIES 2
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,705
Registered: ‎11-04-2008
Message 2 of 3
(1,184 Views)

I have a laptop running Linux Mint which is an Ubuntu based system.

I beleive their latest is based off verizon 14.x.

I have never had a problem connecting to my Verizon routers (two versions of Mi24W as well as Qunatum gateway).

What model router do you have?

Wouldn't think that wireless interface under Linux would be listed as eth0. That is typically for a hardwired interface.

If you don't have any customer configs on it (other than SSIDs), I would try and reset to factory default.

You will have to reconfigure your wireless.

I don't think the default Verizon config blocks anything from connecting to Internet.

 

 


If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.
Silver Contributor V Silver Contributor V
Silver Contributor V
Posts: 402
Registered: ‎07-29-2015
Message 3 of 3
(1,152 Views)

Hello! 

 

Once your connected, can you paste the output of the commandin terminal:  ifconfig

 

This tells you your current network settings, you should (if default) be seeing a 192.168.1.* address somewhere there. Otherwise its a DHCP issue/Network Driver issue. Do you know what network card your device uses? Perhapse do a quick google search for the company and see if they provide any linux drivers for it. 

 

Also, please try pinging an IP address. I have seen a problem before in Ubuntu with DNS and DHCP. Try to ping 8.8.8.8 in terminal. If you get a response, then it most likely is a DNS issue. To check what DNS server ubuntu decided to use, type the following command: cat /etc/resolv.conf

 

Look in that file for the line "nameserver". If there is nothing there, or its set to 127.0.0.1, you would have to set your DNS server manually.

 

These are just a few suggestions, hopefully this post can be useful.  

 

TL;DR Its most likely an issue on the device and its drivers, not the Verizon router. 

 

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.