Accessibility Resource Center Skip to main content
Get it fast with In-Store & Curbside Pickup or same day delivery.

Problem connecting Ubuntu to G1100 at 2.4 G

SOLVED
Reply
Grappa
Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-28-2017

Problem connecting Ubuntu to G1100 at 2.4 G

Message 1 of 9
(2,230 Views)

I am running Ubuntu 17.04 on a Dell laptop.  Dual boot with Windows 10.  My laptop doesn't see 5 G system

Windows 10 connects just fine to the G1100, and we get great internet speed.

Ubuntu connects enough to get a DHCP internet address,  but pings between my laptop and router range from 100 ms to 23000 ms.  Most of the pings are 15000-22000 ms.

The experience varies dramatically between 3 minutes of great performance and then 40 minutes of timeouts and blank screens.

 

I have adjusted many of the G1100 configuration settings, as well as installed wicd to open up a few more variables.  The good news is that almost nothing can break the connection between the laptop and the router.  The bad news is that it is still intolerably slow.

Any ideas?

Thanks,

Grappa

1 ACCEPTED SOLUTION

Accepted Solutions
Grappa
Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-28-2017

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 7 of 9
(2,011 Views)

Thanks for your ideas.   I've been chipping away to figure out the root cause and get my system back to normal.   Didn't like having wicd and networkmanager running at the same time.  Kind of goofy.   I was able to get rid of wicd.  My guess about the root cause...

 

My old router SSID was "starbase".   During the initial setup, when I saw that both 2.4 Ghz and 5 Ghz wifi networks had been named "starbase" by the tech, I renamed my 2.4 Ghz wifi "starbase 1".  Then considered that having a space in my SSID might give me future problems, so I changed the 5Ghz name to "pokeymon" and the 2.4Ghz back to "starbase".

 

Without thinking, I had created 2.4Ghz SSID links to both "starbase" and "starbase 1".

 

I am using networkmanager in Ubuntu, and have been looking for ways to get rid of wicd and get my setup correct.  I decided to delete my settings for "starbase" and set them up again.  That's how I discovered I still had settings for "starbase 1".

 

I used the command "nmcli con", and then deleted references to both SSIDs with "nmcli con delete uuid insert-UUID-here"

 

Then deleted wicd, restarted my computer and things have been very snappy ever since.

View solution in original post

8 REPLIES 8
Smith6612
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,562
Registered: ‎12-15-2010

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 2 of 9
(2,227 Views)

Have you tried disabling power saving to the Wireless card, and also have you ensured that WMM Extensions are enabled within Ubuntu? This can vary based on the chipset in use. Also, your packages are up to date, right?

Grappa
Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-28-2017

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 3 of 9
(2,189 Views)

Thank you Smith6612.  You nudged me in a productive direction.  No fix, but things to try.

 

My Ubuntu software is up to date.  I realize there may be some modem firmware around and I've started looking.  I turned off Power Management.  It didn't solve this problem, but I see where it will avoid some others.

 

I'm not sure how to enable WMM Extensions in Ubuntu.  A link would help.

 

dmesg is telling me: about difficulties communicating with xx:xx:xx:xx:xx:1E, while the MAC address of the router is xx:xx:xx:xx:xx:1DNot sure if this is normal or not.  The message is

wlan0: aborting authentication with xx:xx:xx:xx:xx:1E by local choice (Reason: 3=DEAUTH_LEAVING)

 

I'm suspecting a bug in my wireless driver so I'll be looking around for new firmware.

 

Thanks again for the ideas.

 

Smith6612
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,562
Registered: ‎12-15-2010

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 4 of 9
(2,184 Views)

Sounds good.

 

Is the MAC ending in 1E by chance either a hidden SSID or the 5Ghz SSID broadcast by your router? The G1100 broadcasts a hidden network, and this can be seen with a Wi-FI Analyzer or the airdump tool (I believe that's the name of it) in Ubuntu.

Grappa
Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-28-2017

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 5 of 9
(2,105 Views)

Oh!  The cone of shame!!

 

I found that the network speed was just fine using an install USB drive.  Then I realized it was something I had done...   So, I permanently turned off Power Saving on my wireless card, installed WICD, and executed the command

sudo /etc/init.d/networking restart

That did the trick.

Smith6612
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,562
Registered: ‎12-15-2010

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 6 of 9
(2,102 Views)

Awesome. Glad you've sorted it!

Grappa
Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-28-2017

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 7 of 9
(2,012 Views)

Thanks for your ideas.   I've been chipping away to figure out the root cause and get my system back to normal.   Didn't like having wicd and networkmanager running at the same time.  Kind of goofy.   I was able to get rid of wicd.  My guess about the root cause...

 

My old router SSID was "starbase".   During the initial setup, when I saw that both 2.4 Ghz and 5 Ghz wifi networks had been named "starbase" by the tech, I renamed my 2.4 Ghz wifi "starbase 1".  Then considered that having a space in my SSID might give me future problems, so I changed the 5Ghz name to "pokeymon" and the 2.4Ghz back to "starbase".

 

Without thinking, I had created 2.4Ghz SSID links to both "starbase" and "starbase 1".

 

I am using networkmanager in Ubuntu, and have been looking for ways to get rid of wicd and get my setup correct.  I decided to delete my settings for "starbase" and set them up again.  That's how I discovered I still had settings for "starbase 1".

 

I used the command "nmcli con", and then deleted references to both SSIDs with "nmcli con delete uuid insert-UUID-here"

 

Then deleted wicd, restarted my computer and things have been very snappy ever since.

View solution in original post

Smith6612
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,562
Registered: ‎12-15-2010

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 8 of 9
(2,000 Views)

Glad to hear it's been fixed! Nice work.

Grappa
Copper Contributor
Copper Contributor
Posts: 11
Registered: ‎07-28-2017

Re: Problem connecting Ubuntu to G1100 at 2.4 G

Message 9 of 9
(1,860 Views)

Not to stretch this out, but I have been periodically having slow connections and delays.

 

In the folder /etc/NetworkManager/system-connections I found a file named "starbase".   The file was dated as of the current date.  It appears that this file is written every time I log into my G1100.  This file contains my network password in plaintext, and my sense is that Ubuntu uses this file to automatically connect to my network when I startup the computer.

 

Knowing that an install USB drive worked blindingly fast with my FIOS, I wondered what would happen if I deleted the "starbase" file altogether.  Interestingly, the next time I booted up, Ubuntu didn't try to log me into my network.  I had to log in explicitly but was pleasantly surprised when I got the same high speed I got using the USB install drive.  All the time.  After connecting with the network, the "starbase" file is re-written.

 

I am now in the practice of deleting the "starbase" file before I shut down.  Something in that file is clearly not correct.

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Have a spare Fios-G1100?Learn how to bridge it into your network
Get Started


Covid19

Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.