×

Switch Account

Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Reply
Highlighted
Copper Contributor
Copper Contributor
Posts: 17
Registered: ‎11-07-2012

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 11 of 23
(16,665 Views)

If after you have checked all the usual stuffs you do to troubleshoot a wireless connection (channel, router location, driver update for the wifi adapter, etc., etc.) you still can’t get the full speed, I suggest you to turn off the Actiontec’s wireless radio and hook up a 3rd party AP instead.

 

I had the same issue with my FiOS wireless and solved the problem by doing the above suggestion. I am convinced that there is a problem with the Actiontec. You can read the test in my post here: http://forums.verizon.com/t5/FiOS-Internet/How-to-Get-the-Fastest-FiOS-Speed/td-p/462931/page/2

And if you research this on dslreports.com, you will see many users have the same complaint and they solve the problem by using an AP other than the Actiontec’s.

Highlighted
Copper Contributor
Copper Contributor
Posts: 7
Registered: ‎03-19-2013

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 12 of 23
(16,257 Views)
I turned my Belkin wireless Actionec off and just use my AirPort Extreme and noticed my wireless connections just started working real nice. Going to get another Airport for my man cave to boost the wireless in the basement now.
Highlighted
Contributor
Contributor
Posts: 1
Registered: ‎05-13-2013

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 13 of 23
(15,871 Views)
This thread was very helpful. I have been plagued with slow wifi over the past year. I started looking into it a bit more closely after I purchased a vizio 70" tv and could not get it to connect wirelessly. My actiontec router was set to automatic for the channel. Once I changed it to channel 6, all my problems disappeared and my tv could connect and other devices sped up tremendously. God knows how many hours I would have been on the phone with Verizon and vizio to troubleshoot...with each likely blaming the other. Not sure I understand why this fixed it, but it did... Thanks agin!
Highlighted
Contributor
Contributor
Posts: 2
Registered: ‎08-26-2013

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 14 of 23
(14,970 Views)
I'm having the same problem with slow iPhone WiFi. The windows laptop will get 50/50 but the iPhone and the ipad in the same location gets about 5/8.

So I switched to a new wireless router, I'm using my old Belkin N+ that worked well with Comcast. The problem is STILL PERSISTING!! This makes me think that the packets themselves are being manipulated and/or ranked by the actiontec.

Has anyone else had this problem?
Highlighted
Contributor
Contributor
Posts: 1
Registered: ‎09-07-2013

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 15 of 23
(14,800 Views)
Here is the solution: set your router to support only N clients. This will require to switch your security from WEP to the next level up, WPA. Create a new password and you should get your full speed. In our case, changing the channel did absolutely nothing (all channels were good, the limit was that the router was working as b or g, not as n. I have done this fix on both mine and my friend's Verizon routers and it worked. He uses his on Verizon FiOS, I am using my Verizon router with RCN cable - we were both getting just over 20 Mbps (I was supposed to get 50, he was supposed to be getting 75). After this change, we are both getting close to the theoretical max (when close to the box, when a couple of rooms away, it will drop significantly)
Highlighted
Contributor
Contributor
Posts: 1
Registered: ‎11-15-2013

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 16 of 23
(14,079 Views)

Thanks alot. This worked. It didn't bring my speed to 50mbps but at least it brought it to 20-25.

Contributor
Contributor
Posts: 1
Registered: ‎12-27-2013

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 17 of 23
(13,589 Views)

I just purchased the new action tech router and performance is horrible....

 

I am paying for 75 speed and only getting 25 up and 25 down. Does Verizon provide credit for underdelivery of service?

 

I have a brand new apple mac book pro and i am sitting five feet from the router. 

 

When I plug into the router-- I get 75 mbps speeds.

 

This doesnt make sense?

 

 

Should I buy an apple router or just a new N router to solve the problem?

 

Any other tweeks you can suggest?

 

thanks,

 

 

 

 

 

Highlighted
Bronze Contributor II
Bronze Contributor II
Posts: 119
Registered: ‎09-12-2013

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 18 of 23
(13,531 Views)

Yes. Definately get an N router and hook it up. Directions are here. I wouldn't both getting an Apple router unless you are a big fan because they tend to be overprice. Here is a good guide for choosing a router.

Highlighted
Contributor
Contributor
Posts: 1
Registered: ‎01-26-2014

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 19 of 23
(13,064 Views)

Thank you. Your advice helped. No need to add another router. I actually set up a WPA2 password. Hope this can be easily found with others having the same problem.

Highlighted
Contributor
Contributor
Posts: 1
Registered: ‎09-27-2014

Re: Problem with WIFI slow speeds and Verizon Actiontec MI424WR router

Message 20 of 23
(11,141 Views)

HI ,if you have the latest Gen 3 router then you might want to try this out ,its worth a shot but effective 
step1 :
log into th router>click on wireless settings >click on advanced security settings>click on 802.11.b/g/n>chnage it to performance mode N>apply

step2:
log into the router >click on wireless settings >click on advanced security settings>click on other advaced wirless settings>proceed>change cts mode>auto>cts type>rts_cts>apply

Disclaimer:

Your laptop will disconect post applying these changes ,if you are not on cat5 connection ,but you will regain connectivity in  couple if minutes,if not you would have to do a hard reset to the router .

If your laptop is not b/g/n compatible then these settings might not help ,these settings go perefectly hand in hand with device supporting N wirless cards or b/g/n.

If some of your devices still run on g or b then please turn of these devices  before you make the above mentioned changes .

Devices whihc are currently running on g or b wireless mode might not even connect ,so please check if all your devices are able to connect to your ssid post the above mentioned changes ,if not then you would have to do a hard reset to your router  to give access to all your devices 





Please try those above steps and do revert back with your valuable feedback.


How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Covid19


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.