Switch Account

Quantum Gateway Router - Local DNS not working

Quantum Gateway Router - Local DNS not working

Copper Contributor FIOSfan2013
Copper Contributor
Posts: 18
Registered: ‎01-25-2015
Message 21 of 36


Well, misery loves company.  I just sent a message to greenwave via their "contact us" page at: http://www.greenwavesystems.com/#contact


It more than likely has to be a firmware-related issue, which gives me some hope that it will be corrected in the not-so-distant future....(assuming someone from FIOS is actually reading these posts)!



Bronze Contributor I
Bronze Contributor I
Posts: 74
Registered: ‎05-06-2010
Message 22 of 36

Possibly, however I tried to do the same thing on my Actiontec and it does not seem to wrk there either.  I never actually noticed before because I always added the statics into the drivers\etc\hosts file.

Copper Contributor FIOSfan2013
Copper Contributor
Posts: 18
Registered: ‎01-25-2015
Message 23 of 36


I had been using an Actiontec MI424WR router for 2 years prior to upgrading to the G1100 "Quantum Gateway," and I never had any issues with user-defined DNS entries.  In fact, I relied on their use quite heavily (naming several key components on my LAN by name, instead of IP), which is why I am so eager to see this feature work with the G1100.

Contributor techinnj
Posts: 2
Registered: ‎02-21-2015
Message 24 of 36

Try pinging by FQDN (fully qualified domain name).

Append .fios-router.home to hostname your are trying to ping.

Contributor techinnj
Posts: 2
Registered: ‎02-21-2015
Message 25 of 36

It's been a while for me since I setup a DNS server.

I would have server search local domain first then forward to external caching server.

The Quantum router seems to be forwarding everything by default.

I will dig further.

Copper Contributor FIOSfan2013
Copper Contributor
Posts: 18
Registered: ‎01-25-2015
Message 26 of 36


Yes, assuming the local DNS is running at all, it would seem that all lookups are forwarded to the external DNS servers.   Has anyone had any luck with Greenwave?  

Contributor bobniss
Posts: 3
Registered: ‎03-05-2015
Message 27 of 36

Think I figured this out (Or at least what's causing the router to mess up)


Does anyone (else, besides me) having this problem have host names with spaces in them?  My two Nintendo products (a WiiU and a 3DS) both put spaces in their DHCP replies for their names (or at least spaces show up in the router's DNS Server page).  I was looking at the system error log and I noticed that named was erroring out and the field it didn't like was the 2nd 'word' in the Nintendo systems' hostname.  I Shut down the Nintendo devices (and putting up with the complaints from my 11 year old), rebooting the router and chaning the DHCP lease to 1 (to flush things out).   Now local DNS works as expected (at least nslookup from WIndows gives the expect IP for local machines.


Not exactly problem solved, since the previous Verizon supplied router had no issue with the spaces, but at least a path to a solution (will probably try static IP and hostnames for the affected devices).


PS I haven't re-enabled the devices yet to confirm the problem resurfaces


PPS - Greenwave was less than helpful, they refered me to Verizon and told me to ask for tier 2 support.  Tier 2 support told me to pound sand since I'm not a premium customer.



Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,744
Registered: ‎11-04-2008
Message 28 of 36

Spaces are not legal in a domain name when it comes to DNS.

Ping commands don't know how to process with a space (example: ping Robert's Wii).

Not sure why it worked on the previous version.

If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.
Contributor bobniss
Posts: 3
Registered: ‎03-05-2015
Message 29 of 36

I'm going to spend part of my snowy day a little later on the phone with Nintendo,  trying to see if there's a way to fix it from the that end.   (At least something to do between pushing snow around the driveway!)


Perhaps off topic a little, the distinction here may be permittable spaces (or other octets) in the host vs domain/subdomain name . . .


BTW: While Windows (at least Win7 home) appears to have an issue with spaces, Linux (Fedora 21)  ping and nslookup do support spaces in both host and TLD, though of course they don't resolve to anything:


[bob@xxxxxx ~]$ ping "hello world.my home"
ping: unknown host hello world.my home




[bob@xxxxx ~]$ nslookup "Hello World.My Domain"

** server can't find Hello\032World.My\032Domain: NXDOMAIN


(Interesting that nslookup errors with the octal representaion, but ping does not)


In looking at the DNS request, as captured by wireshark, in both cases the query name reflects the spaces (in both the host and TLD portion. ie the 'query' portion of the DNS request:


0000   0b 48 65 6c 6c 6f 20 57 6f 72 6c 64 09 4d 79 20  .Hello World.My
0010   44 6f 6d 61 69 6e 00 00 01 00 01                 Domain.....                                      .


Note the length fields (0b / 09) include the spaces (20)


In reading the various RFC's its a little muddy to me if spaces are legal, as there are references to octet strings as well as restiction to LetterDigitHyphen.   Wikipedia (OK, not the best of references) Domain_name_system page states "DNS names may technically consist of any character representable in an octet. However, the allowed formulation of domain names in the DNS root zone, and most other sub domains, uses a preferred format and character set." 

Perhaps there may be a distinction with a difference regarding host vs domain/subdomain names.  In the case of the Quantum Router, its clearly a hostname containing spaces problem I believe I am seeing


In addition, RFC 2181 states:

 The DNS defines domain name syntax very generally -- a
                 string of labels each containing up to 63 8-bit octets,
                 separated by dots, and with a maximum total of 255
                 octets.  Particular applications of the DNS are
                 permitted to further constrain the syntax of the domain
                 names they use, although the DNS deployment has led to
                 some applications allowing more general names.  In
                 particular, Section 2.1 of this document liberalizes
                 slightly the syntax of a legal Internet host name that
                 was defined in RFC-952 [DNS:4].
Contributor bobniss
Posts: 3
Registered: ‎03-05-2015
Message 30 of 36

I have what I think is a work-around (the engineer in me) or a solution (the user support in me) to the issue of spaces in DHCP supplied host names. I’ve tested this with my Wii U and 3DS

  • On the offending device, turn off DHCP, and assign statically an IP, netmask, and DNS server.
    1. In choosing an IP, I’ve previously set my DHCP configuration to use >100 for the last octet. In my case, I set the WiiU to .24 and 3DS to .25
    2. I suggest not re-using the IP that was assigned via DHCP, though this may not matter and might only require slight medications to step 3
  • On the Quantum router, Advanced -> DNS Server click Add DNS Entry
    1. Enter a spaceless name and the IP chosen from step 1
    2. Apply
  • It is necessary to ‘purge’ the offending name from the Quantum router.
    1. You can try and wait out the DHCP lease – this might be as long as 1440 hours. Even though there won’t be any connectivity from the device. For the 3DS this didn’t appear to work for me.
    2. I <think> the following should also work (seemed to work for me this morning)
      1. On the Quantum router: Advanced->IP Address Distribution->Connection List
      2. Find the “offending” hostname, select edit
      3. Check the ‘static least type’ box
      4. Apply
      5. Re-edit the host
      6. Uncheck the ‘static lease type’ box
      7. Apply
      8. I <think> this will force the router to try and reset the lease. Since the IP is no longer there (first step), the router should drop the offending name
      9. Note: It might be necessary to manually add a static connection (get the MAC address for the offending device) if not found in step 2.2 above (this was the case for my 3DS)
  • Refresh the Advanced->IP Address Distribution->Connection List, if all went well, the offending hostname should be gone
  • Test via Advanced->Diagnosis and put in the hostname used in step 2. (Might have to apply your local domain name – this seemed a bit inconsistent when I tried various local hosts)  Next step via ping and/or nslookup from host devices
  • Clues to the problem (and if this fixed it) are found on the Quantum Router “System Monitoring” -> “Advanced Status” -> “System Logging”. You can look at the default System Log, or the “LAN DHCP Log”.
    1. Mar  5 17:31:56 2015 local3.warn<156> named[27536]: localnet.zone:20: unknown RR type 'Wii'
    2. Mar  5 17:31:56 2015 local3.err<155> named[27536]: dns_rdata_fromtext: localrev.zone:22: near 'Wii': extra input text


How-To Videos
The following videos were produced by users like you!
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.

Browse Categories

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.