×

Switch Account

Remote Desktop Control using Cisco VPN

Reply
Highlighted
Copper Contributor
Copper Contributor
Posts: 5
Registered: ‎06-29-2011

Remote Desktop Control using Cisco VPN

Message 1 of 6
(3,841 Views)

I am trying to remote into a server at work from home.  My home computer is using Windows 7 Ultimate.  I am using Cisco's VPN software version 5.x.  I can make the connecton, I can ping the servers at work, I can even map netwrok drives, but when I try to use the Remote Desktop Connection to access one of the servers, I get the following error in my VPN log:

 

 
1      05:20:31.490  08/12/11  Sev=Warning/2    CVPND/0xE3400013
AddRoute failed to add a route with metric of 0: code 160
    Destination    192.168.1.255
    Netmask    255.255.255.255
    Gateway    10.0.0.1
    Interface    10.177.8.244

2      05:20:31.491  08/12/11  Sev=Warning/2    CM/0xA3100024
Unable to add route. Network: c0a801ff, Netmask: ffffffff, Interface: ab108f4, Gateway: a000001

 

This was working When I was using Comcast but when I switched to Verizon, it stopped working.  My Verizon Router is a ActionTech MI424-WR.  I can use the remote desktop connection to gain access from other computers but not my home PC.

I am hestitate to go into my router's configuration without knowing what I am doing so any help would be appreciated.

5 REPLIES 5
Highlighted
Nickel Contributor
Nickel Contributor
Posts: 39
Registered: ‎05-28-2011

Re: Remote Desktop Control using Cisco VPN

Message 2 of 6
(3,836 Views)

 

Don,

 

Also try asking for help in this forum:

 

http://www.dslreports.com/forum/vzfiber

 

Lots of really smart people in that forum !

 

-Ken

Highlighted
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,512
Registered: ‎12-15-2010

Re: Remote Desktop Control using Cisco VPN

Message 3 of 6
(3,829 Views)

Change the IP address of the Verizon router from 192.168.1.1 to 192.168.2.1 and see if the problem is solved. You might also need to port forward GRE 47 and TCP 1723 in the port forwarding section of the router.

 

Just remember: Resetting the Verizon router will fix whatever gets messed up from changing settings. It will reset back to the day you got the router.

Highlighted
Gold Contributor VII Gold Contributor VII
Gold Contributor VII
Posts: 2,000
Registered: ‎05-27-2010

Re: Remote Desktop Control using Cisco VPN

Message 4 of 6
(3,818 Views)

So, smith6612 is on the right track I believe.   Looking at what you're trying to connect to at work, it has an IP address of 192.168.1.255.  The problem is that your home network (to which your PC is connected) is also the 192.168.1.x network.

 

The VPN client is seeing the same network in two locations (one local, and one at the far end of the VPN tunnel) and it can't map things such that it's in two places at once.

 

So, your options are:

 

1. Chnage the IP address range of your local network.  Smith6612 suggested going into the router and changing your local network segment to be 192.168.2.x instead of 192.168.1.x.  After making this change, reboot all your devices (Router, PC's, STB's, etc.)

 

2. Change the subnet mask on the local network segment.   Right now it's 255.255.255.0.   Change it to 255.255.255.128.  Again reboot everything and try.   This change should allow you to see "work" systems in the range 192.168.1.128 - 192.168.1.255 (anything below that on the 192.168.1.x subnet would not be visible).

 

3. Ask work to not use the 192.168.1.x network (since it's a very common home network address range) and to change their IP addresses to something in the 10.x.x.x or 172.16.x.x RFC1918 ranges.  Where I work, we specifically avoid the 192.168.x.x range entirely, the 10.0.x.x range and the 172.16.0.0 ranges since these seem ot be the common ranges people use for their local networks.

 

With Comcast, you probably either didn't have a "router" and were directly on the internet using a public address or the router you had used a different default address range (many routers also use 192.168.0.x or 192.168.2.x as their default setting).

 

 

Highlighted
Copper Contributor
Copper Contributor
Posts: 5
Registered: ‎06-29-2011

Re: Remote Desktop Control using Cisco VPN

Message 5 of 6
(3,797 Views)

Thanks all for your help.  I tried changing the IP address on the router but to no avail.  Actually, I'm getting the same error except that it is now referencing the 192.168.2.1 address.  The really strange thing is that I can use one of my XP computers at home and RDC with no problem.  It's only when I try with my computer running Windows 7 Ultimate that I noticed that I could not RDC into any of my servers at work with this particulr computer.

Maybe, I just have a corrupt copy of Cisco VPN version 5.x on my Windows 7 PC.  On my XP computer, I am using VPN version 4.x and as I said, that works fine.

 

Again, thanks to everyone for all of your help.

Highlighted
Gold Contributor VII Gold Contributor VII
Gold Contributor VII
Posts: 2,000
Registered: ‎05-27-2010

Re: Remote Desktop Control using Cisco VPN

Message 6 of 6
(3,775 Views)

Connect to the VPN and then open a cmd window on the Windows 7 machine and post the results of a "netstat -nr" -- Windows 7 may be handling the routing differently than the shim being used by Windows XP.

 

 

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Covid19


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.