Remote Desktop port 3389 through Quantum Gateway router

Reply
Highlighted
Contributor
Contributor
Posts: 1
Registered: ‎01-30-2015

Remote Desktop port 3389 through Quantum Gateway router

Message 1 of 5
(12,517 Views)

I am unable to connect to Windows Remote Desktop (RD) from the internet.  Remote Desktop TCP/UDP port 3389 is configured in port forwarding to the correct local PC.    GRC.com 'Shields Up' service reports port 3389 as 'Stealth'.  If it was exposed with port forwarding I wouild think it would report it as 'Closed' or 'Open' as determined by the PC firewall which is open for RD.

 

Anything I could be doing wrong?

4 REPLIES 4
Highlighted
Bronze Contributor I
Bronze Contributor I
Posts: 74
Registered: ‎05-06-2010

Re: Remote Desktop port 3389 through Quantum Gateway router

Message 2 of 5
(12,486 Views)

I would hazard a guess that you havent set up the pf rule correctly.

I use rdp all the time to several machines with no issues - obviously to do that I have to use a non standard ports for rdp on all but one machine.  Actually a safer thing to do anyway - that's just a change on the rdp listening port in the registry of the machine.

If you select firewall settings and then port forwarding you can then select create a new port forwarding rule

in the right hand drop where it says application select remote desktop and it will show you whatthe rule should look like

 

Basically it should be tcp any -> 3389

                                       udp any -> 3389

and the ip address or name of the device

Note that under advanced you can change the destination port 

so you could set your pf rule to tcp any -> 9090

and destination port to 3389 so not having to change the listening port on the server

To access remotely your mstsc destination would then be YOUR WAN address:9090

 

This description is different dependant on the router you are using.  The description here is for the Actiontec rev I - the worst port forwarding setup for any of the routers as there is no way to edit a setting so forcing you to recreate them each time

Highlighted
Bronze Contributor II
Bronze Contributor II
Posts: 163
Registered: ‎09-30-2013

Re: Remote Desktop port 3389 through Quantum Gateway router

Message 3 of 5
(12,448 Views)

To expand upon ViaFax's instructions,   to reach your network from the WWW you need to address the public IP of your router not the private IP 192.168.1.1.

 

Also be aware that from time to time your public IP will change.  You can work around this by installing a Dynamic DNS service that will automatically update your public IP address by provinding you a host name to use instead of an IP.  BlueRouter.homeftp.net  is an example of a host name whose public IP will automatically be updated whenever Verizon assigns your router a new public IP.

Highlighted
Contributor
Contributor
Posts: 1
Registered: ‎09-19-2015

Re: Remote Desktop port 3389 through Quantum Gateway router

Message 4 of 5
(11,755 Views)

Hi,

 

I recently switched to Verizon FIOS and have a Quantum gatway - which seems to have a complicated set up for portforwarding.

 

For RDP client, the forwarding worked well on the default port 3389, and that was easy.

 

However, I wanted to use a different port in the external IP (WANIP : port ) , but not able to figure out how to set this up in the router - any help is appreciated.

 

The advanced settings have very complicated set up as below:

 

 

Custom Ports                       
Advanced Settings
Local devices listed            Application To Forward...           
UDP             Both           Source Ports
            Any           Specify           
Destination Ports
            Any           Specify           
Protocol
            TCP           
Specify           Schedule
            Always                      
Forward to Port
            Same as Incoming Port           
Highlighted
Gold Contributor VII Gold Contributor VII
Gold Contributor VII
Posts: 2,153
Registered: ‎11-10-2009

Re: Remote Desktop port 3389 through Quantum Gateway router

Message 5 of 5
(11,703 Views)

Basically you define the listening port on the redirected item.

So

 

desvice                           Application and Ports Forwarded     Wan Connection Type

192.168.1.99:3389         Destination Ports 1489                        All Broadband devices         Active

                                           TCP Any -> 1489

 

 

I'd show the screen print but it's ridiculously small and I don't know how to make it bigger, never used to be like that.

 

That was done with the Actiontec Rev I, the gateway may be different.

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Covid19


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.