Switch Account

SSL certificate error

Contributor Parker3743
Posts: 2
Registered: ‎07-20-2018
Message 1 of 16

Anyone seen this error when attempting to access router settings from the Fios app?? Started a couple of weeks ago. I’ve tried rebooting the router and uninstalling and reinstalling the app. Still have the same problem.

MVP Smith6612 MVP
Posts: 7,367
Registered: ‎12-15-2010
Message 2 of 16

Any chance you can get the error details causing the SSL warning to occur? I'm not familiar with the app in particular, but typically routers cause this becauese they use self signed certificates, which typically nothing trusts by default.

Contributor Jeff-L
Posts: 2
Registered: ‎10-27-2012
Message 3 of 16

Yes! It's killing me. I've been unable to connect to the Internet setting section in the "My Fios" iPhone app for a few weeks. I haven't had time to finish troubleshooting it yet nor sit on the phone with Verizon for an hour...


Please let us know if you've found a solution.

Contributor Fus
Posts: 1
Registered: ‎09-04-2018
Message 4 of 16

Has anyone found a solution to this yet? It worked fine for years. I recently upgraded my speeds and with that came a new router.  Ever since the install, I get the SSL certificate error.

Contributor DMSverizonuser1
Posts: 1
Registered: ‎09-03-2018
Message 5 of 16

I upgraded my wi-fi and got a new router.  I downloaded the fios app.  Trying to manage my internet but keep getting ssl certificate error. Help! I keep calling Verizon but no help 😩

Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,705
Registered: ‎11-04-2008
Message 6 of 16

Try twitter @verizonsupport

If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.
Contributor CNeverleave
Posts: 2
Registered: ‎10-24-2018
Message 7 of 16

Hi, did you ever find a resolution to this? Been driving me bonkers for about 5 months now. Thank you!!

Contributor yiyi
Posts: 2
Registered: ‎12-05-2018
Message 8 of 16

Same issue here.  Very frustrated.  Anyone knows how to fix it? 

Contributor Mamo1
Posts: 2
Registered: ‎07-18-2019
Message 9 of 16

Open the wifi window in settings on your phone.  The network associated with the new router should be displayed.  Connect to the basic 2.4 link.  when the connection is made you will see a small letter i in the id line. Click on that and you willsee the info for that link. There is also a renew lease button.  renew the lease and the app will now be allowed to work with the router.

Contributor Mamo1
Posts: 2
Registered: ‎07-18-2019
Message 10 of 16

If you renew the lease on the network server the app will work.  To do this you open settings on your phone and click on wifi.  Connect to the basic connection which is the 2.4G service.  when you are connected you may see a small letter i on the id line. click on that and look for renew lease.  Click on renew lease and renew the lease.  I did that and now my myfios app works with the router.  Good luck. My device is an iPhone. I do not know what to do with a Android.

How-To Videos
The following videos were produced by users like you!
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.

Browse Categories

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.