Customers With Disabilities
quick menu

Samsung Blu-Ray cannot connect wirelessly to Internet through router

Samsung Blu-Ray cannot connect wirelessly to Internet through router

Device: MI424WR-GEN2
Plan: Consumer Bundle Plan
Location: Fairfax, VA
Message 1 of 5

I have Verison FIO service and an Actiontec MI424WR-GEN2 wireless router.

My Samsung Blu-Ray BD-C5500 player is connected wirelessly to my router using a Samsung LinkStick Wireless Adaptor USB 2.0, Model number: WIS09ABGN 
I am able to connect my Blu-Ray to the router, but I'm unable to connect to the internet.  
The Blu-Ray's internet test checked MAC address, IP Address, Subnet Mask, Gateway, and DNS Server, and a Gateway Ping. The internet service test failed though with the following message:
"The HTTP port is disabled. Please check if the HTTP port is blocked by something like the internal firewall program."
I logged into my router to look at the administration settings and noted the firewall settings for my router are set at "Typical Security (Medium)".
Can you tell me how I can solve this connectivity problem?
Gold Contributor VII
Gold Contributor VII
Message 2 of 5

#1 In the router go to Advanced -> IP Address Distribution.


#2 If the router's DHCP range is 192.168.1 (2-254), change that so that it is 192.168.1 (100-254)


#3 What is the current HTTP port that your Samsung Blu-Ray BD-C5500 is set to use?

If you are the original poster (OP) and your issue is solved, please remember to click the "Solution?" button so that others can more easily find it. If anyone has been helpful to you, please show your appreciation by clicking the "Kudos" button.


Device: MI424WR-GEN2
Plan: Consumer Bundle Plan
Location: Fairfax, VA
Message 3 of 5

I was not able to find information on the port used by the Blu-ray player for connecting to the internet.

The IP range was originally set from 2 to 254.  I did try resetting the IP range but that didn't work.  I returned the range back to 2 to 254.


I did three things that together seemed to solve the problem.  

1. Upgraded the Samsung blu-ray firmware from version 1014 to 1015.4.  The Samsung website has the firmware and instructions to load it using the USB port.

2. In the Actiontec router's admin window: -> wireless settings -> basic security settings, I turned on WEP.

3. In the blu-ray network setup, I used the WEP key to reconnect to the router instead of my WPA2 password.

4. Network tested fine and is now working.


My advise is to first check the firmware version and install the latest version manually if you have to.



MVP tns2 MVP
Message 4 of 5

For the browser it is port 80.  Which pretty much is likely to be open.  Are you talking the browser or a particular app.  My Samsungs (4 of them) never had long term problem connecting to anything on the Internet except for apps that Samsung dropped support for.  E.g. they dropped support for the Verizon app on some (all?) year versions of their players.


Did you change the default security level of the router? 


And you really don't want to use WEP.  Its almost like using no security since there are programs that can crack it in seconds.  Go back to WPA2





Platinum Contributor II
Platinum Contributor II
Message 5 of 5

On another note using WEP. If you are using an MI424WR Rev. F or newer, using WEP will decrease your wireless performance to that of Wireless G. That means you probably won't see more than 20Mbps Wirelessly. Whereas routers like the Rev. I can be capable of over 70Mbps with WPA2 security.

My Rewards+
Start earning points Enrolling in My Rewards+ is quick, free and easy

Refer A Friend
Refer friends to the Verizon Fios Family, and earn 10,000 My Rewards+ points
Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.

My Verizon

  • Check Email
  • Add or Change Services
  • Suspend My Service
  • Manage Services
  • Apps


Watch Fios