×

Switch Account

Verizon router replacing source ip for incoming traffic

Verizon router replacing source ip for incoming traffic

Reply
Contributor fiosra
Contributor
Posts: 1
Registered: ‎12-02-2019
Message 1 of 2
(145 Views)

Hi,

 

I recently switched to Verizon Fios GigE service from cablevision. I do a port forwarding to internal machine for ssh (port 22). I have some rules based on failed login attempts to ban the ip (fail2ban software). SInce I switched to FIOS, I can no longer use that as verizon does a NAT for incoming traffic as well and all of the traffic from outside seems to come from 192.168.1.1 (router ip). Ideally this should only be done for outgoing traffic where the source ip gets replaced with public ip and not for incoming traffic. Is there a setting in router that can fix this behavior?

 

Thanks,

1 REPLY 1
Copper Contributor corbulon
Copper Contributor
Posts: 23
Registered: ‎03-12-2012
Message 2 of 2
(47 Views)

I'm surprised you're having this problem -- when I ssh into my servers from afar, the servers see me connecting from the remote host, not the router. And that, of course, is how things should be...

One of these servers is the DMZ host, and the other's ssh-port is reached via port-forwarding. For both of them connections look as one'd expect...

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.