Switch Account

Weird DNS issue

Contributor WXIXW
Posts: 3
Registered: ‎06-10-2019
Message 1 of 5

Hi, I come across a very weird DNS issue.


Initially, I was using an automatic DNS server and couldn't connect to Google and a bunch of other websites, except for every one or two hours (yes, sometimes it works but not after a few refreshing). The error info is dns_probe_finished_no_internet. So I just changed my DNS servers to (also tried OpenDNS, Cloudflare). That solves connecting to Google (mostly) but the same problem still exists with my university website, DMV, etc. I have no such problems when I am at school or using 4G on my cellphone. So I am pretty sure this lies with Verizon Fios itself.


Any ideas on how to tackle this problem? Maybe things other than DNS involved here. Thanks!

Silver Contributor V Silver Contributor V
Silver Contributor V
Posts: 206
Registered: ‎01-01-2018
Message 2 of 5

Does this issue perisst when using a different browser?


Have you tried pinging while still connected to your wifi?

Contributor WXIXW
Posts: 3
Registered: ‎06-10-2019
Message 3 of 5
Yes, the problem exists whether chrome or safari. Ping is perfect when using Google public DNS. But still, a bunch of websites is super slow and encounter DNS problem. Even getting on fios forum could have this issue.
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,752
Registered: ‎11-04-2008
Message 4 of 5

Seems strange because FIOS has no control over an external DNS.

You are going straight to their server.

Where did you make this change?

In your PC?

If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.
Contributor WXIXW
Posts: 3
Registered: ‎06-10-2019
Message 5 of 5

No, I changed it through the setting webpage of the router ( Changing through my Mac Network setting still doesn't work very well.


If FIOS directly goes to an external DNS, then where is this issue from? It's haunting me for a while. I just get FIOS for less than 2 weeks.

How-To Videos
The following videos were produced by users like you!
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.

Browse Categories

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.