×

Switch Account

STB not powering on

Reply
Highlighted
Contributor boquesy
Contributor
Posts: 1
Registered: ‎09-30-2009
Message 1 of 2
(2,479 Views)

My STB is not powering on - everything is tightly plugged in, checked the electricity, it's all fine.

 

I tried resetting the router, didn't work. I tried resetting the STB, didn't work. It's HD & DVR.

 

Could there be something wrong with the box itself? I have other STBs in the house and they all work fine. This one seems to be the only one not turning on! The time doesn't even appear. Nothing lights up.

 

Not sure what to do - need help.

1 REPLY 1
Highlighted
Gold Contributor VII
Gold Contributor VII
Posts: 2,325
Registered: ‎08-05-2008
Message 2 of 2
(2,450 Views)

If pulling the power fo 30 seconds does not cause the box to re-boot then you have a dead box and need to call Verizon.  They will UPS a new box and you can return the defective one free at any UPS store (they will include a pre-paid return label).

If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.
How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.