Customers With Disabilities
quick menu

Unable to use FiOS Mobile Remote App on Samsung Galaxy Tab 2

Unable to use FiOS Mobile Remote App on Samsung Galaxy Tab 2

Message 1 of 8

I'm one of the holdout Blackberry customers who Verizon doesn't recognize as wanting apps anymore.  I finally broke down and bought an Android tablet device when I saw the FiOS Mobile Remote App and recognized it as an easy solution for controling my multiple HD STBs in my "Man Cave".  Unfortunately, the app has been completely useless.


The app loads fine.  I'm able to register each HD STB with the app, however doing anything more than the initial set-up for the remote function results in a crash.  Every time I attempt to use it, I get the message "Unfortunately, FiOS Remote has stopped."  I will occassionally see the attempted connection displayed on the corner of my TV screen.


All other functions of the app work, including the DVR function.


I've reported this failure for months, using the handy little report button below the crash message.  No response.


I've commented on this topic in threads from other users with the same problem.  No response.


I've posted to the comments section of the Google Play store.  No response.


Please, would someone from Verizon acknowledge this problem exists?  My best theory so far is that my tablet device is not on a Verizon data plan (WiFi only), so therefore Verizon isn't interested in supporting it (or this loyal customer). 


Device is Samsung Galaxy Tab 2, 7.0, running Android 4.0.4.  All FiOs STBs replaced with latest generation.

Message 2 of 8

I am sorry to hear about the troubles you are having with the app. We try to make the app as compatible with all devices as possible. The full list of devices the mobile remote is compatible with is   . You may find there may be devices that do work with it that re not on the list, but these are all verified working devices with the app. Since yours doesn't appear to be on the list, we can not gaurantee it will work. Submitting all the feedback has gotten word back to Verizon about the troubles you are having. You can also submit this to the Verizon Idea Exchange. Please search on the idea exchange and cast your vote. There may be another member who made the same suggestion. If not, please add a new idea so your fellow community members can comment and vote on your suggestion.  . The Verizon Idea Exchange is there for you to submit your ideas and suggestions to Verizon so that we can consider them as we innovate our products and services.


**If someones post has helped you, please acknowledge their assistance by clicking the red thumbs up button to give them Kudos. If you are the original poster and any response gave you your answer, please mark the post that had the answer as the solution**

Notice: Content posted by Verizon employees is meant to be informational and does not supersede or change the Verizon Forums User Guidelines or Terms or Service, or your Customer Agreement Terms and Conditions or plan

Message 3 of 8

I am having simlar problems with a twist:


I have a Galaxy Tab 7 Plus that until yesterday had Android 3.X Honeycomb.  The Fios Remote app worked fine on this for many months with just an occasional glitch.  


Yesterday the tab upgraded to Android 4.04 (Ice Cream Sandwich)  and the Fios Remote app now crashes exactly as described by the original poster.  I tried uninstall/re-install with the same results consistently.   So it appears that the Fios Remote application will not work on ICS.  This is a big disappointment, as I found the Remote app very useful.



Silver Contributor III
Location: Long Beach, California
Message 4 of 8

When the Android app force closes, are you sending the report to the developer?  This option should come up when you get the force close.  If it does, then forward it.  You may be able to add the details you've posted here.  It might get the problem to the app developer in a more timely manner.

Message 5 of 8

I did allow sending of the crash report on a few of the times while retrying to connect with the remote application.  I hope that speeds up the ability of VZ engineers to build an update.  But I'm not holding my breath.  If this doesn't have a widespread impact, there won't be a big rush to fix this.  VZ gets to claim they have an Android remote application whether it works with most devices or not.   I'll keep checking from time to time because I thought it was a great app, but I'm prepared to remain disappointed. 

Message 6 of 8

Only one reason for the fios remote app not to work on Samsun Galaxy tablet 2.


Message 7 of 8

Your list of compatable devices shows samsung galaxy 7, but the remote control does not work on that divice.

Will anyone from verizon really respond to this?



Silver Contributor III
Location: Long Beach, California
Message 8 of 8

I opened a support case and Verizon acknowledged the problem and a fix is on it's way (probably sometime later this century). I was told to "keep an eye out for it" in the Play store. We'll see. This is funny because the app worked fine with older Android versions before Jelly Bean. It impacts more than just tue Galaxy by the way.

My Rewards+
Start earning points Enrolling in My Rewards+ is quick, free and easy

Refer A Friend
Refer friends to the Verizon Fios Family, and earn 10,000 My Rewards+ points
Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.

My Verizon

  • Check Email
  • Add or Change Services
  • Suspend My Service
  • Manage Services
  • Apps


Watch Fios