Customers With Disabilities
quick menu

Can't connect ROKU to an Actiontec GT704WG rev B router - I'm baffled

Can't connect ROKU to an Actiontec GT704WG rev B router - I'm baffled

Message 1 of 7
Verizon replaced my wireless router/modem Actiontec GT704WG with a newer, but same model router. Only difference is the new one says rev B after the part #. I can't connect my roku to it, and I am going crazy. I spent 1 hour chatting with roku support which got me nowhere - except I can rule a lot out. I power cycled and reset the roku box. I even reset my router. I tried connecting with all wireless security disabled. The router firewall is turned off and wireless is set to channel 11. No matter what I do, it can't connect to the box (the first step after selecting the appropriate network - it sees my network). I can connect to another person's wireless without any problem. Any help is much appreciated, otherwise I am stuck with an expensive door stopper. Ethernet connection is not an option and neither is stealing a neighbor's wireless. Thanks for your help! -jon
Message 2 of 7

Does the ActionTec by any chance have an option to force a specific wireless mode, such as wireless G or Wireless B instead of the typical Mixed Mode they are set to by default? You'll find such options often times under the Advanced Wireless Settings. Try forcing it to use Wireless G to see if it will connect. If not, I would have to say it's possible there's an incompatibility between the Roku's Radio and the ActionTec radio.


If your old ActionTec is still working, you're free to put it back in service and keep the newer ActionTec as a spare should your old ActionTec router die on you. If that isn't an option, you can see if one of Verizon's Westell 7500s may work, or you can try setting up another wireless router as an access point if you have that option. Otherwise, if you absolutely cannot get any wireless solution working, you could look into getting either a MoCa connection or an Ethernet over Powerline solution set up so that the Roku will work over an Ethernet connection. That's obviously a last ditch effort from the sounds of things.

Message 3 of 7
I tried G-only but it didn't work. I'm really stumped by this. I guess I'll see I can get the old wireless box set up. Although it might have been the cause of my internet problems that Verizon had to address in the first place. Thanks for your help. -jon
Message 4 of 7
I tried b-only and that made some progress. It "connected to wireless" but could not connect to the "local network". Third step is connecting to the internet. I can see the roku boy when I click on 'my network' in the actiontec modem. I was able to get it fully working when I hooked up an ethernet cable. So something is different about the latter steps when wireless vs. wired. Any additional suggestions are much appreciated. This is the first progress anyone has been able to make! thanks, -jon
Message 5 of 7

Good to hear some progress was made. If you log into the ActionTec again and look around at the "Advanced" section, do you see a Firmware Upgrade option? See if you can upgrade the modem firmware via the modem's interface. If that doesn't work, I'll see if I can locate a link for your modem.

Message 6 of 7

I am not a verizon customer but experienced the same issue with my GT704WG and rokus. Actually it was also a problem with my vizio tv running netflix. The problem seems to be that the netflix devices don't play nice with the actiontec router when the dns servers are hardcoded in the router setup. Once I told the router to get them from the isp the rokus could function properly, however, the old roku worked flawlessly and the new high def xd/s occassionally lost track of the router and I had to flip the router power off and on to get the roku to see it again. This usually happened a couple times a week.


I did finally cure that problem, and a few others, completely by installing openWRT on the router, but it was like pulling teeth to get the wireless set up correctly. If you are linux friendly, or a massochist, you can try openWRT, it offers more control than any firmware supplied by actiontec or verizon or quest, but it's no picnic to install and get running on the actiontec. You can get a version of openWRT with a gui from x-wrt if you go that route.


Let me say one more time though, I am a linux user and it still took me the better part of 2 days to get that running and configured properly.

Message 7 of 7

My Roku will not connect to the internet. I have a Verizon GT704-WGB. The Roku worked fine with my older Belkin and modem. 

 With help by Roku support and Verizon support , I have changed the channel, I changed the DNS I also changed the DMZ . The DMZ made the Roku work for half a day.  


By reading your comment I should bought another Belkin instead of going with the GT704.... It sounds to difficult to go  the route of , installing openWRT on the router.  


My Rewards+
Start earning points Enrolling in My Rewards+ is quick, free and easy

Refer A Friend
Refer friends to the Verizon Fios Family, and earn 10,000 My Rewards+ points
Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.

My Verizon

  • Check Email
  • Add or Change Services
  • Suspend My Service
  • Manage Services
  • Apps


Watch Fios