×

Switch Account

Concurrency Issue?

Reply
Contributor pbannist
Contributor
Posts: 3
Registered: ‎04-26-2011
Message 1 of 6
(719 Views)

I'm not 100% sure of the issue I'm having but I think it has to do with concurrent downloads of files.  Based on my testing I'm pretty sure the issue is with my Westell 327W or with the DSL connection itself, but won't have time to call Verizon for a few days so figured I'd post here for now.  

 

I've had Verizon DSL for about 6 or 7 years now and while it's not amazing, it's been totally fine.  In the last few days I've had serious performance issues with my connection, at least in certain scenarios.  I'll just list out everything I've seen:

 

 

  • Download speed (what router is reporting, and from speed testing) looks like 3360 Kbps - which is the same as it has always been and is totally fine - for a single file.
  • Upload speed (again router reported and speed test confirmed) is only 224 Kbps - I am pretty sure this is dramatically down from 768Kbps (or similar),  but I don't remember.  I am suspicious this may have something to do with my problem.
  • If I'm downloading a single web page (testing Chrome and Firefox 4.0), it is fairly slow - and from watching the connections (using Firebug in Firefox) I can see that nearly no activity is happening concurrently, everything is waiting for the last file to finish.  So for a page with 100+ objects, it takes quite a while as there is a ton of blocking.
  • If I start downloading a file it basically blocks any other Internet usage.  It is extremely slow to do anything in any browser at this point - e.g., loading my newsfeed in Facebook can take up to a minute and usually just times out (last week this would've taken a few seconds)
  • If I'm streaming something (e.g., Youtube), I get worse performance on other pages than doing nothing but not as bad as a straight file download. 
  • I've tested this on 3 separate laptops on Wifi as well as directly connected to the router via Ethernet.  Also have tested with my Android phone connected to Wifi.  All testing shows exactly the same problem.
  • I have the router in bridge mode and use a Linksys E3000 for my primary Wifi (has been this way for a year).  When moving any files locally (e.g., pulling a file off one laptop and onto another) I have none of these issues, file transfer speed is high and if I use the net I am not "blocked" by this network activity.
  • I live in Manhattan - no FIOS in my neighborhood yet:(
  • Nothing has changed - I haven't logged into my Westell or 327W in months - although obviously have since this issue started
  • And I have rebooted both routers and my laptops repeatedly during this testing.
So this points to the fact that something has happened to my DSL connection where I can't download multiple files at the same time (or very close to this).  I think it may be related (or caused by) the drop in upstream speed - i.e., the DSL can't keep up with the outbound requests as they are flooding the small upstream channel that is also being used for control, etc.
I just don't know if that's the real issue, and even if it is, not sure if there is anything I can do aside from calling Verizon. Any thoughts? Much appreciated!

 

5 REPLIES 5
Contributor pbannist
Contributor
Posts: 3
Registered: ‎04-26-2011
Message 2 of 6
(717 Views)

And figured since it can't hurt to post, here are the transceiver stats:

 

Transceiver Revision: 7.2.3.0  

Vendor ID Code: 4  

Line Mode: G.DMT Mode  

Data Path: Interleaved    

Transceiver Information

  Downstream Path Upstream Path

  DSL Speed (Kbits/Sec) 3360 224

Margin (dB) 15.0 11.0

Line Attenuation (dB) 35.0 31.5

Transmit Power (dBm) 10.5 11.8

Silver Contributor V
Silver Contributor V
Posts: 631
Registered: ‎12-17-2009
Message 3 of 6
(677 Views)
You are correct, you should be able to download and browse at the same time. If your network has wireless capability are you sure U do not have a hacker stealing your access? There are many things U can do to secure wireless and if you want my list let me know by responding. When I was having issues a long time ago I had g.DMT and Interleaved When It was changed to Line Mode ADSL_2plus and Data Path FAST My issue was fixed (this was about 1 year ago, of course this required a call to verizon. BTW cool avatar.Hoep this helps, if not I am sure one of the experts here will help you out! See my recent solved post to compare stats, You are very perceptive the upstream is low!!! Good luck josea
If a forum member gives an answer you like, please give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem. Thanks !!!
http://forums.verizon.com/t5/Verizon-net-Email/Fix-for-Missing-Inbox-sent-folders-etc-with-Internet-Explorer-11/m-p/647399
Platinum Contributor III
Platinum Contributor III
Posts: 5,881
Registered: ‎07-22-2009
Message 4 of 6
(672 Views)

 

Also remember, if you are uploading too much that will severely impact your downloading. See this link.  
Why decreased download while uploading

 

It might also just be a simple TCPIP problem, it sounds like it to me at least.  The upload is definetly something to consider as well.

 

So run the TCP Optimizer at http://www.speedguide.net/downloads.php

 

 

And if that doesn't help - then isolate some of your equipment and run those transceiver stats again.

 

Here's some good links to help with that. 

 

How do I check the modem at the NID?

Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,379
Registered: ‎12-15-2010
Message 5 of 6
(657 Views)

Your line is having a noise issue on the upstream. If you have access to your NID, plug the modem into the test jack found inside of the Customer access portion of it and post up the new statisitcs. If the inside wiring is at fault, your upstream should sync at 864kbps. If it doesn't, there's an issue on Verizon's end that should be solved. From there, we'll worry about the issues regarding your download speed.

Contributor pbannist
Contributor
Posts: 3
Registered: ‎04-26-2011
Message 6 of 6
(602 Views)

Thanks for all of the tips.  No one aside from me is accessing my Wifi - it's password protected and I checked both routers and I know all of the machines that are connected.

 

I don't have access to the NID, so the last thing I did was just move the router much closer to the wall jack and swap the phone cable with a new one - and that didn't improve anything.

 

Got in touch with Verizon on the phone and they're running a line test for the next 24 hours but the woman saw the problem and was just confirming whether it is at the CO or something to do with my outside wiring.  I'll wait and hopefully it is fixed soon.  Thanks all!

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.