Customers With Disabilities
quick menu

New computer (windows 7) connection problem with Verizon DSL

New computer (windows 7) connection problem with Verizon DSL

Message 1 of 7

I just bought a new computer to replace a dead one.  I took the old one away and plugged the new one into the Verizon cable.  I have Verizon DSL, no wireless, no network at home, just a computer and a Westell modem.


On the new computer, I have a successful internet connection in that I can reach Google.  I can conduct a Google search, but when I click on a search result I cannot reach that site.  I CAN successfully send and receive Gmail.  I CANNOT connect to Verizon's website, Amazon, Washington Post, Ebay, or most other sites.  What happens when I try is a small box comes up in the browser window saying "Connecting to [name of site]" and the in-progress thing goes around and around.  This will go on for as long as I let it (more than 1/2 hour), with no timeout or failure message -- just an empty browser window.  Results are the same in Explorer and Firefox.


I hooked a borrowed computer into my Verizon line and the internet connection works fine to any site I try (I'm on it now).  Verizon techs have also done a line test and it's fine.


I have taken the new computer (running Windows 7) back to the store 3 times.  They have hooked it into an Earthlink DSL line there and have shown me they have no difficulty whatsoever going to any of the sites that are not working for me at home.  They say the problem MUST be something to do with my Verizon connection.


I've called Verizon tech support 3 times now.  They say it's not them, and there's nothing they can do -- but their Remote Assistant software isn't able to connect IN to my machine, just as I can't connect OUT to the Verizon site.  I have asked for a more up-to-date modem and was refused.


I was tempted to just upgrade to FIOS but Verizon is being so unhelpful I am ready to bail on Verizon entirely.  Before I do, can anyone suggest what might be going on here? 

Platinum Contributor I
Platinum Contributor I
Message 2 of 7

A problem very similar to this was posted up back in August by a user who had gotten a new laptop that gave the same results. Their solution? Replace the modem with something newer. See if you can get Verizon to send you a new modem or borrow a spare modem from someone to see if things start to work for you.

Message 3 of 7


I bought an HP computer at Staples and had the same problem.  HP and Verizon could find no problems.  Verizon said the would send me a new modem to see if that fixed the problem. The problem was corrected after Verizon sent me a new modem for free. 

Message 4 of 7

I am also having the same issue. Hopefully, when my new modem arrives it fixes the problem.

Message 5 of 7

I just had a similar experience with connectivity.  After replacing an old HP desktop running XP( which always ran well)  to a new one running widows 7, I experienced so many different problems, and spent many hours with both HP and verizon technical support that I could possibly work as a trouble shooter for either one.  Verizon agreed to send a new router, and they did, but its the wrong one. HP told me that an encryption problem exists w/in Verizon( something about the government worried about vulnerability)  and that it wouldn't happen with any other server.  Long story short,I took the new one back and am using the old one.  Too bad  because it was a gift for my son. I know I have several gray hairs from this experience and am just waiting for the real scoop before I venture into a new setup again.  Having set up several computers in the past 18 years, it was very frustrating to go through all that and still have no real resolution.  Wish me luck and respond if you have anything else to add. Misery loves company, and perhaps a good chuckle too..... I'm still wating for the new router.!

Message 6 of 7



Solved this issue...please see below.


My grandparents just bought a new computer Windows 7 x64, so for about 3 days now they have been having the same issue as the person that started this forum in which my cousin has been going around in circles trying to figure it out along with contacting verizon support.  After the 3 days my cousin called me to ask me if I can help with the issue, so I did some trouble shooting myself (I have 10 years experience as a systems engineer on Windows, UNIX, and Linux Servers but started out at a helpdesk), so I was able to successfully see an internet connection in that I could reach Google's website.  I was conduct a Google search, but when I clicked on a search result from google it was waiting on the site like it wasn't routing correctly.  I was successfully able to send and receive Gmail via google.  But wasn't able connect to CNN's website, Foxnews, facebook, and numberous other sites.  These results were the same in IE, Google Chrome, and Firefox.  I tried flushing the DNS, clearing the browser cache, swapping cables, etc.  Now the uncanny part was that there old computer running Windows XP ran fine without any issues at all, but the Windows 7 computer wouldn't connect to the internet.  I took there computer to my house in which I run Comcast internet and the computer worked great with no issues, and I took my laptop running Windows 7 to there home and it didn't work there but works fine at my house.  So I called Verizon Tech Support (BIGGEST WASTE OF MY TIME EVER!!!!) which was my last option always, and they keep going around and around in circles with things I already did.  I ask the tech support guy if there was a new version of firmware (Firmware was 04.XX.XX)  for the Westell 6100 Modem (2006 DATE) that my grandparents were running and twice they told me NO.  So I had Verizon (after going back and forth) ship a new modem (Westell 6100g) out to the house which when I plugged it up and activated it, I directly went to the new modem in a browser and noticed that the Modem's firmware was at Version 05.XX.XX.....So just for me I decided to do some homework online and found a link (which is below) that has the latest firmware updates for the Westell 6100 Modem, and I download/installed it on the old modem that wasn't working with the Windows 7 and then connected without any issues!!  So I believe the issue is that the older firmware versions are able support the new Windows 7 OS or IP stack (v4 and v6).  All in all the fix is to either update your firmware or have Verizon send you a new modem, either way will resolve the issue.  I think verizon need to realize this issue and update they modem to support the correct OS's.  I want Verizon to know that I WAS ABLE TO RESOLVE THIS ISSUE, I THINK VERIZON OWES ME MONEY INSTEAD OF PAYING THERE CRAPPY TECH SUPPORT PEOPLE!!



Platinum Contributor I
Platinum Contributor I
Message 7 of 7

To say the least, the modems should be updating their firmware automatically. Back in 2008 Verizon pushed new firmware to my modem which I was not happy about, a Westell 6100 from 2005, but I haven't seen issues with any machine behind an old Westell and v4.*.*.* firmware, back before I had gotten my current router and bridged the modem. It's good to know that newer firmware is out for the modems (they are barely ever updated), though. Might be a new solution besides asking people to have a new modem sent to them.

My Rewards+
Start earning points Enrolling in My Rewards+ is quick, free and easy

Refer A Friend
Refer friends to the Verizon Fios Family, and earn 10,000 My Rewards+ points
Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.

My Verizon

  • Check Email
  • Add or Change Services
  • Suspend My Service
  • Manage Services
  • Apps


Watch Fios