Customers With Disabilities
quick menu

OpenDNS with Verizon Versalink 7500 with Firmware and DHCP

OpenDNS with Verizon Versalink 7500 with Firmware and DHCP

Message 1 of 6

I have scoured the interwebs for this and this is my last shot.  Does anyone know how to configure the Verizon 7500 with FW & DCHP, to use OpenDNS? The one page I found on Verizon said "You cannot use static DNS server settings when using DHCP mode." It may be that this is not possible? Thanks!

Platinum Contributor II
Platinum Contributor II
Message 2 of 6

I've found the options for setting custom DNS Servers to be lacking in many Modem/router combination units. If the Westells allowed for the configuration of some "advanced" DHCP settings, I could tell you a command to enter that would allow you to specify what servers you want to use and completely ignore those offered up by the WAN connection. For now, I assume the only way to enter in custom DNS Servers into the combination units that don't support Telnet/SSH/GUI options for changing them would be to set up the modem for Static IP. That of course requires a Business account with Verizon to do.


Your best bet unfortunately is to set up each PC individually to use OpenDNS. If the modems allow for the direct editing of the DNSMasq settings, you'd want to use this command:




The above command alone will give PCs those IPs for DNS the next time they renew their DHCP lease or request a new DHCP-issued address.

Platinum Contributor II
Platinum Contributor II
Message 3 of 6

I stand corrected with my above post. To change the DNS servers the Westell uses, you will want to go to My Network > Network Connections > DSL Connections and edit the VC Connection you see in there. In the edit screen, you will see two DNS servers that are Verizon's. Fill in as replacement servers OpenDNS's IP addresses. Click Apply. Within a few seconds your PPPoE Connection WILL drop as the modem reloads some components in memory. Give it 20 seconds to do this (write data to flash, reload modules, etc) and then visit My Network > Network Connections and press the Connect Button for the DSL connection. PPPoE will come right back up and you'll be using OpenDNS.

Message 4 of 6

Thanks, Smith6612, but that will not work for me.  I am in California, and Verizon has us on DHCP i.e. Routed Bridge, not PPPoE. I had found what you suggested somewhere else, but again, with DHCP, I cannot put in DNS servers.  I tried changing the DHCP to be static IP (which is the only way to put in DNS servers), but then my connection would not work.

Gold Contributor VII
Gold Contributor VII
Message 5 of 6

#1 In the router go to Advanced -> DNS Server (page 115 in the manual that is at )

#2 This is, I believe, where you can define/set the DNS Server(s).


If you are the original poster (OP) and your issue is solved, please remember to click the "Solution?" button so that others can more easily find it. If anyone has been helpful to you, please show your appreciation by clicking the "Kudos" button.


Message 6 of 6

Actually there is a way arround this using another WIFI router.  In my config I am using a Linksys WRT54G but any router should work.


1) Cabling will connect from any port on the Verizon 7500 router/ modem to the internet port on the other router. In the verizon modem disable the private lan and dhcp server under the advanced config.  Update the device password so the kids dont get it and reenable dhcp. 


2) Set up a Static NAT with another subnet to your other wifi router(my static nat is to:  Verizon router runs on , set your other router to something like  The static nat you input on the verizon modem will be to your other router. So  your going to have to set your other router to that ip address.   


3) Setup your other router to "static ip" address configuration to the internet, mine is set to, Mask:, Gateway verizon modem), Static DNS will be both of your Opendns IP's( and  Set your internal LAN up on your other router how you see fit but not on the subnet, mine is just starting with address, Start with Local ip address:


This isnt as air tight as doing it directly on the modem but it works. These instrutions should be good enough to get  you going, good luck!



My Rewards+
Start earning points Enrolling in My Rewards+ is quick, free and easy

Refer A Friend
Refer friends to the Verizon Fios Family, and earn 10,000 My Rewards+ points
Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.

My Verizon

  • Check Email
  • Add or Change Services
  • Suspend My Service
  • Manage Services
  • Apps


Watch Fios