Accessibility Resource Center Skip to main content
Get gifts fast with In-Store & Curbside Pickup or same-day delivery.

Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet

SOLVED
Reply
Highlighted
Copper Contributor
Copper Contributor
Posts: 6
Registered: ‎06-28-2014

Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet

Message 1 of 4
(122,728 Views)

Although I defintely do have internet access, I noticed that in System Preferences/Network, although the W-Fi status is "On" this statement is below: "Wi-Fi has the self-assigned IP address 192.168.1.46 and will not be able to connect to the Internet." There is a yellow dot preceding the "Wi-Fi / Self-Assigned IP" icon on the far left of the System Preferences/ Network window. The Network Diagnostics shows all the items under Network Status as green. I have the original Westell 6100F modem provided by Verizon in 2008. Is this statement: “Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet" still a problem that needs correcting? Thank you.

 

I have OS X Mavericks (10.9.5) and an Airport Time Capsule purchased in 2014.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,547
Registered: ‎12-15-2010

Re: Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet

Message 2 of 4
(122,641 Views)

A 192.168.xxx.xxx address is usually not self assigned. Self assigned would be 169.254.xxx.xxx addresses, which appear if a computer could not complete DHCP. It could mean that the computer is not using DHCP, but is instead set up with a Static IP in this case.

 

Check to make sure DHCP is enabled by going to System Preferences > Network > select Wi-Fi / Airport > select Advanced. From here, select TCP/IP, and make sure "Confgure IPv4" and "Configure IPV6" are set to "Use DHCP" and "Use Automatically" repsectively. Then, go to the DNS tab. Clear out any servers you see here by selecting their IP Addresses and clicking the Minus sign.

 

When you save these settings, your computer should be able to get online again.

 

By the way, since OS X Mountain Lion has reached End of Support for software and security updates, you may want to upgrade the system to OS X El Capitan when you have a chance. It's free via the App Store.

View solution in original post

3 REPLIES 3
Highlighted
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,547
Registered: ‎12-15-2010

Re: Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet

Message 2 of 4
(122,642 Views)

A 192.168.xxx.xxx address is usually not self assigned. Self assigned would be 169.254.xxx.xxx addresses, which appear if a computer could not complete DHCP. It could mean that the computer is not using DHCP, but is instead set up with a Static IP in this case.

 

Check to make sure DHCP is enabled by going to System Preferences > Network > select Wi-Fi / Airport > select Advanced. From here, select TCP/IP, and make sure "Confgure IPv4" and "Configure IPV6" are set to "Use DHCP" and "Use Automatically" repsectively. Then, go to the DNS tab. Clear out any servers you see here by selecting their IP Addresses and clicking the Minus sign.

 

When you save these settings, your computer should be able to get online again.

 

By the way, since OS X Mountain Lion has reached End of Support for software and security updates, you may want to upgrade the system to OS X El Capitan when you have a chance. It's free via the App Store.

View solution in original post

Highlighted
Copper Contributor
Copper Contributor
Posts: 6
Registered: ‎06-28-2014

Re: Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet

Message 3 of 4
(122,634 Views)

 

Smith6612 wrote: 

Check to make sure DHCP is enabled by going to System Preferences > Network > select Wi-Fi / Airport > select Advanced. From here, select TCP/IP, and make sure "Configure IPV6"...set to "Use Automatically"... Then, go to the DNS tab. Clear out any servers you see here by selecting their IP Addresses and clicking the Minus sign.

By the way, since OS X Mountain Lion has reached End of Support for software and security updates, you may want to upgrade the system to OS X El Capitan when you have a chance. It's free via the App Store.


 

 

Thanks so much. By the way, I have Mavericks OS 10.9.5.

This was the window before before I tried your suggestion.

 

 wi-fi yellow.jpg

 

"Configure IPV6" was set to "Link-local".

In the DNS tab. The Minus sign was not available .

 

This is the window now.

 

wi-fi green.jpg

Highlighted
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,547
Registered: ‎12-15-2010

Re: Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet

Message 4 of 4
(122,569 Views)

Looks great now. You should be all set 🙂 Glad that helped.

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Covid19


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.