×

Switch Account

2 subnets with one FIOS router

2 subnets with one FIOS router

SOLVED
Reply
Highlighted
Contributor Jin356b
Contributor
Posts: 1
Registered: ‎09-18-2014
Message 11 of 14
(15,588 Views)

I figured out a way to get these P0S routers to NAT all my internal networks, WITHOUT having to add a secondary NAT router in between. Say for instance my default internal network is 192.168.1.0/24, and the verizon router's internal IP is 192.168.1.1. Then I have 2 internally routed networks: 192.168.2.0/24 and 192.168.3.0/24. To get the verizon router to NAT the 192.168.2.0/24 and 192.168.3.0/24 nets, you have to trick it into thinking that these networks are part of it's default internal network.

 

1. Go the router's My Network -> Network Connections -> edit LAN

2. Click the Settings button

3. Scroll down to Routing Table and click New Route

4. Enter the routes to your internal networks. Ensure you leave the metric at 0.

5. Repeat steps 3 & 4 for all your internal networks

6. Apply the settings.

7. At this point all your internal networks should be able to communicate with one another (provided you setup each device's default gateway correctly).

8. Go back into the LAN connection settings page

9. Scroll down until you see the IP Address and Subnet Mask fields. The IP Address should already be set to 192.168.1.1. Change the subnet mask to 255.255.0.0.

10. Apply the settings.

 

This will trick the router into NATing all 192.168.x.x networks. And the static routes you entered in step 4 will ensure the 'incorrect' subnet mask doesn't break internal routing. I Hope this helps all you Enterprise Network admins that are stuck using this crap... 

Highlighted
Contributor HollyW00d
Contributor
Posts: 1
Registered: ‎09-26-2014
Message 12 of 14
(15,555 Views)

I just wanted to reply and say THANK YOU.  I was just setting up my lab at home and was about to thrown my monitor on the floor because I could not get my second subnet on the internet.  After attempting numerous static routes and firewall rules I was going to give up until I saw your post.  

At least now I know it's this crappy router, and not what I was doing that was causing the router to not forward NAT for that second subnet.

Highlighted
Contributor hndcb
Contributor
Posts: 1
Registered: ‎10-11-2014
Message 13 of 14
(15,515 Views)

Here is an interesting document from Actiontech indicating how to create different VLANs :

 

http://support.actiontec.com/doc_files/Creating_an_Ethernet_VLAN.pdf

 

It will provide great flexibility to control the MI424WR unit.

 

Highlighted
Contributor Sobak
Contributor
Posts: 1
Registered: ‎10-03-2015
Message 14 of 14
(14,392 Views)

I know this is an old posting but THANK YOU, I've been dealing with VLAN problems for about 4 weeks now, gave up on the Fios router and decided to install a Cisco1841 behind my Fios, everything was working well but my VLAN's not on 192.168.1.x were not routing.  Found you post and everything is working now!!!!

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.


Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.