quick menu

Refer a friend

Reply
Highlighted
Contributor Gimcheng
Contributor
Posts: 1
Registered: ‎01-03-2019
Message 1 of 1
(199 Views)

I installed services in august through a referal, I received the credits for it as well as the promotion for the $200 Google/Nest product credit and $150 Visa Prepaid card. Soon after I had referred a friend using my code, they had signed up for the triple play and recieved their $150 card and service as well. But when this appeared, I thought, oh finally.
image.png
But I go to click it and go to the rewards page

image.pngI only see my previous reward for the 150. As I mentioned earlier I had already activated the card. I have used the card already. But I can't register for the new card for refering a friend. I go to hit "Check reward status" and it tells me to activate my card again. I input all the information and it just says the card is already activated, which I have done previously. Anyone else have this issue?

Also I would like to point out

 image.png

The fio rewards still appears even though I have already received and activated it. 

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.



Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.
 

My Verizon

  • Add or Change Plan
  • Suspend My Service
  • Apps

Support

Watch Fios