×

Switch Account

Change to smtp.verizon.com from outgoing.verizon.com - sendmail configuration

Change to smtp.verizon.com from outgoing.verizon.com - sendmail configuration

Reply
Contributor nigelhorne
Contributor
Posts: 4
Registered: ‎09-01-2013

What is the configuration needed for sendmail?  I'm running under Ubuntu 13.04.  Setting up the smart_host stuff and authorization is easy, but I can't remember how to force sendmail to connect to port 465.

 

-Nigel

5 REPLIES 5
Gold Contributor II Gold Contributor II
Gold Contributor II
Posts: 4,437
Registered: ‎12-16-2012
Message 2 of 6
(4,472 Views)

Look at this page http://verizon.com/emailsettings

 

As far as where these settings go in email under Ubuntu, I have no idea.

Contributor nigelhorne
Contributor
Posts: 4
Registered: ‎09-01-2013
Message 3 of 6
(4,463 Views)

Thanks, but those tell you the values to set which I know.  What I can't firgure out is how to get sendmail to work.

 

I've added this to sendmail.mc:

 

define(`SMART_HOST', `smtp.verizon.net')dnl
define(`RELAY_MAILER_ARGS', `TCP $h 465')dnl
define(`ESMTP_MAILER_ARGS', `TCP $h 465')dnl

But when I try to drain the queue I get this:

 

Running /var/spool/mqueue/r82D31IG002661 (sequence 1 of 18)
{edited for privacy}@verizon.net... Connecting to smtp.verizon.net. port 465 via relay...
{edited for privacy}@verizon.net... Deferred: Connection reset by smtp.verizon.net.

-Nigel

Silver Contributor II
Silver Contributor II
Posts: 631
Registered: ‎12-17-2009

Nigel, Disclaimer: I was rated 1/10 on a scale for Linux skills, but I did find this http://www.moundalexis.com/tm/2010/10/28/getting-past-verizons-residential-smtp-block-with-sendmail/

If a forum member gives an answer you like, please give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem. Thanks !!!
http://forums.verizon.com/t5/Verizon-net-Email/Fix-for-Missing-Inbox-sent-folders-etc-with-Internet-Explorer-11/m-p/647399
Contributor nigelhorne
Contributor
Posts: 4
Registered: ‎09-01-2013

Thanks for the pointer.  In fact I'd found that before I posted on here.  However it relates to the old outgoing.verizon.net, not the new smtp.verizon.net.  In particular it doesn't solve the port 465 problem where I can't connect to it even using telnet.

 

-Nigel

Contributor nigelhorne
Contributor
Posts: 4
Registered: ‎09-01-2013

I believe that I have it fixed and can now use Sendmail to send mail out again.

 

The pointer is at http://www.dawoodfall.net/index.php/relaying-sendmail-a-ssl which shows where Virgin Media in the UK pulled the same stunt as Verizon.  It doesn't quite work as mentioned, you need to put the relay domain in square brackets to avoid MX resolution, however apart from that it's sweet.  I didn't set up relay-domain as mentioned.

 

Briefly, to enable using sendmail to deliver mail on FIOS:

 

1) install stunnel

2) Create /etc/stunnel/smtp.verizon.net.conf with:

 

sslVersion = SSLv3

[ req ]
client = yes
accept = 2525
connect = smtp.verizon.net:465

 

3) /etc/init.d/stunnel restart

4) Add sendmail.mc:

 

define(`SMART_HOST', `[localhost]')dnl
define(`RELAY_MAILER_ARGS', `TCP $h 2525')dnl
define(`ESMTP_MAILER_ARGS', `TCP $h 2525')dnl

 

5) Add to authinfo:

 

AuthInfo:fqdn.of.your.localhost "U:name" "PSmiley Tongueassword" "MSmiley TongueLAIN"

AuthInfo:fqdn.of.your.localhost:2525 "U:name" "PSmiley Tongueassword" "MSmiley TongueLAIN"

6) cd /etc/mail && make && /etc/init.d/sendmail reload

 

And it's done.  Easy when you know how!

 

-Nigel

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.



Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.