Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu

Web pages get redirected to foreign country sites

Posts: 2
Registered: ‎05-14-2012

Web pages get redirected to foreign country sites

Message 1 of 5

I've been having this problem for over a year now with a variety of websites.  Today while doing some searches on Expedia, eventually the page got redirected to what I think was the Vietnamese version of the Expedia site.  The Vietnamese is actually a new phenomenon.  It used to be that I was always redirected to the Mexico sites, and that happened with Groupon & Open Table mostly.  Once the redirect happens, I am unable to revisit the site until the following day when my router has cleared its cache.  Obviously I understand I could clear the cache manually so as to be able to visit the site again, but who wants to have to do that? 


When this first happened, it was when trying to visit the Groupon website.  I got redirected to the Mexican page, and it even would change the emails I was receiving to the Spanish language versions.  I had no idea what was happening, had a computer geek friend look into it, had Norton do remote scans for viruses.  Nothing worked & we couldn't figure out what was happening.  I eventually contacted Groupon to let them know it was happening.  Their very first question to me was:  Is your ISP Verizon?  Obviously, the answer is yes, and they said that they were aware of this happening but only with Verizon customers. 


So my question is:  Is there something I can do on my end to fix this issue or am I just stuck with getting hijacked whenever it floats Verizon's boat to do so?

Moderator Moderator
Posts: 2,403
Registered: ‎03-10-2011

Re: Web pages get redirected to foreign country sites

Message 2 of 5

Just a friendly reminder, this is a forum where users help other users. It looks like your issue may require a Verizon representative to review your account details. Please contact our customer service team via live chat or email at:

Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,634
Registered: ‎12-15-2010

Re: Web pages get redirected to foreign country sites

Message 3 of 5

That doesn't make sense. I don't see how it could be a Verizon problem unless they've got some sort of proxy set up on your connection that routes you through other nations first for even reaching the general Internet. That's very inefficient network design and makes no sense from my view and Verizon's view.


I would check your system's Locale settings. I've seen a system having incorrect locale settings causing redirects to non-US websites when the browser headers are sent to the web server. I would also try different DNS servers, in case they were changed or are set to Verizon's DNS servers (to rule out Verizon's only way of really goofing this up).


Your system could be set to say it's from a completely different region and yet, still use English. Make sure your location is set to United States!



Posts: 2
Registered: ‎05-14-2012

Re: Web pages get redirected to foreign country sites

Message 4 of 5

Well, it doesn't make sense to me either.  I'm not savvy enough to understand how all of these things work.  I've only learned over the past year plus how to deal with it when it occurs.  But it being a Verizon issue makes sense to me because I'm using a desktop & a laptop computer, both of which were also used when I had AT&T as my ISP, and this NEVER happened until I moved & switched to Verizon for my ISP. And as I said, Groupon knew of this as an issue for Verizon customers. 


BUT, just in case, I did as asked and checked.  But everything in the Region & Language Options shows the English/US.  I don't know what or how to switch DNS servers. 

Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 6,172
Registered: ‎09-24-2008

Re: Web pages get redirected to foreign country sites

Message 5 of 5

@eezelpreezel wrote:

I don't know what or how to switch DNS servers. 


To check what the DNS Servers are, that depends on the version of Windows..


Usually it is:

#1 You go to Start


#2 Then go to Run.


#3 Type in cmd and press enter.


#4 Type in ipconfig / all and press enter.




If you don't want to do that, you can:


#1 Go to


#2 Download the program.


#3 No install is needed 🙂


a) Could just run it but security wise, that is not a good idea.


b) I would suggest scanning it for malware with your malware scanner.


#4 Open up the program.


#5 In the DNS Server tester: The system DNS servers are listed at top with-in a box in the Name Server Tab.




If you don't understand what DNS Servers are the system DNS Servers, listed in that program - this is what you could do.


#1 In the Name Server tab, click on Add/Remove


#2 Click on the button, Remove All Name Servers.


#3 Click on the botton, Add System's Nameservers




To set the DNS Servers:


#1 You will notice at the webpage that I pointed you to, it has a link called Configuring your DNS Nameservers


#2 Click that link.


#3 There he:


a) List pros and cons of where the setting is setup.


b) Ponts to info from OpenDNS of how to define the DNS Server(s), since that is one site that he has found telling users how to do it.

If you are the original poster (OP) and your issue is solved, please remember to click the "Solution?" button so that others can more easily find it. If anyone has been helpful to you, please show your appreciation by clicking the "Kudos" button.


How-To Videos
The following videos were produced by users like you!
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Have a spare Fios-G1100?Learn how to bridge it into your network
Get Started


Browse Categories

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.
Modal Dialogue Title