Accessibility Resource Center Skip to main content
Get it fast with In-Store & Curbside Pickup or same day delivery.

Who Me Too'd this topic

robbychen
Copper Contributor
Copper Contributor
Posts: 9
Registered: ‎01-31-2020

Cannot connect to Google or other Google products but can ping to the sites

(8,227 Views)

Hi,

 

I discovered this issue yesterday morning when I tried to search for something on Google and displayed "Can't connect" message. Gmail and other websites have been working fine except google.com. I tried restarting my router and it worked fine for a few moments. After that, google.com worked fine but it was Google Photos that cannot connect to. I tried restarting my router one more time, this time was YouTube that was not working correctly (all of the video thumbnails were not shown). I tried to restart the router one last time, and it went back to google.com not working.

 

I tried ping google.com in the command line and it pinged successfully. However, I cannot connect to the site in the browser. Neither on Windows 10, nor on Mac, nor on iPhone (that's all the devices I own). I also tested on different browsers, the results were the same.

 

Can someone help me solve this issue, and why does it only affect Google-owned sites?

 

Thanks,

Robby

Who Me Too'd this topic