Accessibility Resource Center Skip to main content
Get up to $500 when you bring your phone. Plus, waived smartphone activation fee when you buy online. Limited time offer.
end of navigation menu

Why isn't the filter working?

Reply
webmail-user
Copper Contributor
Copper Contributor
Posts: 18
Registered: ‎04-14-2011

Why isn't the filter working?

Message 1 of 6
(1,156 Views)

I get annoying spam in the Spam Detector from a sender that I will refer to as XYZ for this question. Using Settings/Email Settings/Filters, I added a new filter "If From Contains XYZ delete" and saved the new filter. Today I got another spam in the Spam Detector from the same XYZ sender. Why isn't the filter causing this email to be automatically deleted? Thanks for any suggestions.

5 REPLIES 5
walt178
Gold Contributor II
Gold Contributor II
Posts: 991
Registered: ‎11-06-2012

Re: Why isn't the filter working?

Message 2 of 6
(1,126 Views)

I was able to duplicate your problem.  Other filters I've used work, so I don't know why that one doesn't work.

Suggestions:  Try making a suggestion in the Verizon idea exchange.   Or call tech support.

 

webmail-user
Copper Contributor
Copper Contributor
Posts: 18
Registered: ‎04-14-2011

Re: Why isn't the filter working?

Message 3 of 6
(1,089 Views)

Thanks for your input. I suppose I could just set Spam filtering to "Delete incoming spam".

walt178
Gold Contributor II
Gold Contributor II
Posts: 991
Registered: ‎11-06-2012

Re: Why isn't the filter working?

Message 4 of 6
(1,079 Views)

@webmail-user wrote:

Thanks for your input. I suppose I could just set Spam filtering to "Delete incoming spam".


That's not an option I would use. Periodically email I want ends up in the spam folder and auto delete of spam would cause me to lose those messages.

somegirl
Platinum Contributor II Platinum Contributor II
Platinum Contributor II
Posts: 3,149
Registered: ‎09-15-2009

Re: Why isn't the filter working?

Message 5 of 6
(1,050 Views)

@webmail-user wrote:

I get annoying spam in the Spam Detector from a sender that I will refer to as XYZ for this question. Using Settings/Email Settings/Filters, I added a new filter "If From Contains XYZ delete" and saved the new filter. Today I got another spam in the Spam Detector from the same XYZ sender. Why isn't the filter causing this email to be automatically deleted? Thanks for any suggestions.


I think that the Spam Detector runs before your custom filters, and custom filters only work on the inbox folder. If Spam Detector moved it from the inbox before the filters were run, then the filter wouldn't delete it.

--
If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.

"All knowledge is worth having."
webmail-user
Copper Contributor
Copper Contributor
Posts: 18
Registered: ‎04-14-2011

Re: Why isn't the filter working?

Message 6 of 6
(1,045 Views)

somegirl wrote:

I think that the Spam Detector runs before your custom filters, and custom filters only work on the inbox folder. If Spam Detector moved it from the inbox before the filters were run, then the filter wouldn't delete it.


Thank you. I hadn't considered that possibility but I do see that I haven't received an email from the sender in question since 06-19-13 (which is promising).

 

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Have a spare Fios-G1100?Learn how to bridge it into your network
Get Started


Covid19

Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.
Modal Dialogue Title