Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.

Asserting OpenDNS on Verizon Quantum Gateway G1100 ?

SOLVED
Reply
OrlandoS
Contributor
Contributor
Posts: 2
Registered: ‎07-19-2014

Asserting OpenDNS on Verizon Quantum Gateway G1100 ?

Message 1 of 5
(4,354 Views)

Just received and setup the latest Verzion wireless router, walking through all the options, turning off uPNP, etc.

 

However, I see no way to assert alternatIve DNS service, e.g. OpenDNS with this router and the manual only privides Prrimary/Secondary DNS settings for default disabled IPv6.

Does anyone know how specific IPv4 DNS Primary/Secondary IPs for the router (and therefore Clients) can be asserted- specifically for OpenDNS?

1 ACCEPTED SOLUTION

Accepted Solutions
gs0b
Platinum Contributor I Platinum Contributor I
Platinum Contributor I
Posts: 2,105
Registered: ‎12-02-2012

Re: Asserting OpenDNS on Verizon Quantum Gateway G1100 ?

Message 2 of 5
(4,342 Views)

I have OpenDNS configured on the Quantum Gateway.  It's easy.

 

  1. Log in to the router.
  2. Click "My Network."
  3. On the left side click "Network Connections."
  4. Click on "Broadband Connection"
  5. Click the "Settings" button at the bottom of the screen.
  6. Enter the OpenDNS server's in the primary and secondary DNS server boxes.
  7. Click Apply.

Enjoy faster DNS lookups and/or web site filtering.

 

 

View solution in original post

4 REPLIES 4
gs0b
Platinum Contributor I Platinum Contributor I
Platinum Contributor I
Posts: 2,105
Registered: ‎12-02-2012

Re: Asserting OpenDNS on Verizon Quantum Gateway G1100 ?

Message 2 of 5
(4,343 Views)

I have OpenDNS configured on the Quantum Gateway.  It's easy.

 

  1. Log in to the router.
  2. Click "My Network."
  3. On the left side click "Network Connections."
  4. Click on "Broadband Connection"
  5. Click the "Settings" button at the bottom of the screen.
  6. Enter the OpenDNS server's in the primary and secondary DNS server boxes.
  7. Click Apply.

Enjoy faster DNS lookups and/or web site filtering.

 

 

BjmQ
Contributor
Contributor
Posts: 2
Registered: ‎06-03-2018

Re: Asserting OpenDNS on Verizon Quantum Gateway G1100 ?

Message 3 of 5
(3,301 Views)

This works, but how can I force all traffic through the Gateway to use the Open DNS servers? I went to my iPad, asked it to use Goggle's DNS, instead of the routeur-provided DNS, and it worked, meaning that my iPad "escaped" Open DNS.

Smith6612
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,611
Registered: ‎12-15-2010

Re: Asserting OpenDNS on Verizon Quantum Gateway G1100 ?

Message 4 of 5
(3,291 Views)

To do this, set the Firewall on the router to Custom. Then, you'll need to create rules which follow this methodology.

 "Allow Port 53 TCP/UDP Outbound to OpenDNS IPs 208.67.220.220 and 208.67.222.222, Source Port Any, Source IP any"

 

"Deny Port 53 TCP/UDP Outbound to all IP addresses, Source Port Any, Source IP Any"

 

Although I don't have a FIOS G1100 or MI424WR handy to do a walk-through on this, the rule of thumb is to create your deny rule to precede the rule to only allow OpenDNS. Then, to test as you've done, the changes. Make sure that making queries against the router (192.168.1.1 or whatever you have it's IP set to) continue to work, and also be sure that you can query OpenDNS directly as well (eg: nslookup www.google.com 208.67.220.220). While queries sent to Google DNS for example (eg: nslookup www.google.com 8.8.8.8) time out.

 

Here's an example of some rules I have set up on Ubiquiti UniFi networks I manage. to restrict DNS traffic to OpenDNS only. I also have rules for IPv6 because these networks are on an IPv6 capable ISP and are IPv6 functional as well.

 

1.PNG2.PNG3.PNG4.PNG5.PNG6.PNG7.PNG

BjmQ
Contributor
Contributor
Posts: 2
Registered: ‎06-03-2018

Re: Asserting OpenDNS on Verizon Quantum Gateway G1100 ?

Message 5 of 5
(3,191 Views)

Thank you very much.

I didn't do all you said but it look like it is working, meaning that when I manualy set 8.8.8.8 as the DNS on my iPad, instead of "Automatic", my iPad doesn't access internet at all, whereas when I let the DNS as "Automatic", it accesses internet but gets blocked by Open DNS where it should.

On the routeur settings, I went to Firewall, Access Control, Add rule, and I created a rule that applies to any device or networked Computer, and which forces any TCP or UDP request, from any port, to go to port 53. It doesn't look like my router allows more "sophisticated" rules where I could specify OpenDNS address here.

Screenshots:

:Routeur rule 1.pngRouteur rule 2.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

I also manualy forced my server to use Open DNS as DNS provider as per the post above. With that, when I do the nslookup queries as you suggest, I time out for 8.8.8.8 and also for 208.67.220.220, but not for my router's IP address. I seem to be able to access the internet fine.

 

 

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Have a spare Fios-G1100?Learn how to bridge it into your network
Get Started


Covid19

Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.
Modal Dialogue Title