Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.

Connect times are dreadful, related to DNS

SOLVED
Reply
amrsos
Copper Contributor
Copper Contributor
Posts: 6
Registered: ‎02-15-2014

Connect times are dreadful, related to DNS

Message 1 of 10
(4,317 Views)

I had FiOS installed on Tuesday 11-Feb-2014. I got it, but I don't get it. 15/5 tier, Actiontec M1424WR-Gen3I, 40.21.10.2 firmware. I'm running Vista and my browser is Firefox 27.0.1. I experienced the problem with a wired connection yesterday, before  I pinpointed DNS. I  have not tried wired since.

 

speedtest shows consistent 15.xx/5.xx, as promised and expected. It's connecting to speedtest.net (or any website for that matter) that is the problem. I gathered data using Network Monitor in firefox that led me to the conclusion that the problem is DNS. I am using OpenDNS on my computer.

 

I've been trying to track this down for 2 days, and here's the latest:

 

Here are the results of  "ipconfig /all" at 5ish pm after a restart. Connections times were all good.


Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Intel(R) Wireless WiFi Link 5100
   Physical Address. . . . . . . . . : 00-21-6B-4E-13-A0
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::34d6:b35:3b1f:3f99%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Saturday, February 15, 2014 5:12:13 PM
   Lease Expires . . . . . . . . . . : Sunday, February 16, 2014 5:12:13 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 285221227
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-10-A7-F6-AF-00-1C-7E-B8-CD-B7
   DNS Servers . . . . . . . . . . . : 208.67.222.222
                                       208.67.220.220
   NetBIOS over Tcpip. . . . . . . . : Enabled

I played a game for an hour (plants-vs-zombies if you must know) in a private browsing session for about and hour, then left the computer for two hours. Computer and router both on. When I returned at 8ish, connect times were dreadful again.

 

When I ran ipconfig /all again at 8 pm this is the result:

 

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Intel(R) Wireless WiFi Link 5100
   Physical Address. . . . . . . . . : 00-21-6B-4E-13-A0
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::34d6:b35:3b1f:3f99%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Saturday, February 15, 2014 5:12:13 PM
   Lease Expires . . . . . . . . . . : Sunday, February 16, 2014 7:11:12 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 285221227
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-10-A7-F6-AF-00-1C-7E-B8-CD-B7
   DNS Servers . . . . . . . . . . . : 2001:558:feed::1
                                       2001:558:feed::2
                                       208.67.222.222
                                       208.67.220.220
   NetBIOS over Tcpip. . . . . . . . : Enabled

 

The only difference is in the DNS servers. How did this happen and how can I stop it from happening  ? This could be a deal breaker. I have not contacted Verizon support yet.

 

Thanks in advance for any advice or solution you can provide.

1 ACCEPTED SOLUTION

Accepted Solutions
Smith6612
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,611
Registered: ‎12-15-2010

Re: Connect times are dreadful, related to DNS

Message 2 of 10
(4,296 Views)

Try disabling IPv6 on your Wireless adapter. Right now FiOS doesn't have support for IPv6 connectiivty to the Internet (although the router will use IPv6 locally on your network!), so your PC could be trying to visit a site using IPv6 first. This causes hangs.

 

To do this, go to your Network Connections section of the control panel, right click your wireless network adapter and select properties. From here, uncheck the box for Internet Protocol version 6, and then hit OK.

 

When Verizon rolls out IPv6 you should turn this option back on. Let us know if this helps.

View solution in original post

9 REPLIES 9
Smith6612
Platinum Contributor III Platinum Contributor III
Platinum Contributor III
Posts: 7,611
Registered: ‎12-15-2010

Re: Connect times are dreadful, related to DNS

Message 2 of 10
(4,297 Views)

Try disabling IPv6 on your Wireless adapter. Right now FiOS doesn't have support for IPv6 connectiivty to the Internet (although the router will use IPv6 locally on your network!), so your PC could be trying to visit a site using IPv6 first. This causes hangs.

 

To do this, go to your Network Connections section of the control panel, right click your wireless network adapter and select properties. From here, uncheck the box for Internet Protocol version 6, and then hit OK.

 

When Verizon rolls out IPv6 you should turn this option back on. Let us know if this helps.

PJL
Gold Contributor V
Gold Contributor V
Posts: 2,069
Registered: ‎08-07-2008

Re: Connect times are dreadful, related to DNS

Message 3 of 10
(4,273 Views)

Normally, the DNS for FiOS is the Verizon provided Actiontec router as primary with a Verizon DNS server as secondary.  The DNS settings are set in Vista and it looks like you are not using the DNS servers provided by the DHCP server since they show as OpenDNS servers, not Verizon servers.  You need to change your Vista network settings to obtain the DNS server address automatically.  It appears to be defaulting to OpenDNS servers.

amrsos
Copper Contributor
Copper Contributor
Posts: 6
Registered: ‎02-15-2014

Re: Connect times are dreadful, related to DNS

Message 4 of 10
(4,267 Views)

Thanks Smith6612. I have done as you suggested and I will monitor it for the next day or so and report back.

 

Cheers.

amrsos
Copper Contributor
Copper Contributor
Posts: 6
Registered: ‎02-15-2014

Re: Connect times are dreadful, related to DNS

Message 5 of 10
(4,266 Views)

Thanks PJL. I pinpointed the problem to DNS during my troubleshooting phase and found lots of support from the internet-at-large to use OpenDNS. That works fine and fast up until the system aquires the IPv6 address for DNS. I am going to leave that be for now, and have disabled the IPv6 adapter as Smit6612 suggested.

 

Thanks again.

amrsos
Copper Contributor
Copper Contributor
Posts: 6
Registered: ‎02-15-2014

Re: Connect times are dreadful, related to DNS

Message 6 of 10
(4,254 Views)

Hold on...this does not answer one important question. How and why did this happen? How did an ipv6  DNS address get provisioned while the computer was ostensibly idle (I don't think there was a browser session open, I will do further monitoring)? I just visited a 6 only site (www.sixonly.eu), and my settings have not changed (I currently have ipv6 adapter enabled). And since VZ has not implented IPv6 support, I submit this should be changed on the Verizon/router end since this  causes serious performance issues. I have searched the router manual and found nothing that addresses this. I'm going to read up on the router's security log. In the meantime, any thoughts?

PJL
Gold Contributor V
Gold Contributor V
Posts: 2,069
Registered: ‎08-07-2008

Re: Connect times are dreadful, related to DNS

Message 7 of 10
(4,251 Views)

@amrsos wrote:

Hold on...this does not answer one important question. How and why did this happen? How did an ipv6  DNS address get provisioned while the computer was ostensibly idle (I don't think there was a browser session open, I will do further monitoring)? ...


I have not run Vista for years, but in WIndows 8.1 (and before) the PC has both a DHCPv6 IAID and DHCPv6 Client DUID.

Is that what you mean?  Or that the IPV6 protocol was enabled in Vista?  It's enabled by default in Windows 7, 8 and 8.1 when you add a network connection.  I can check my old Vista machine the next time I turn it on.

amrsos
Copper Contributor
Copper Contributor
Posts: 6
Registered: ‎02-15-2014

Re: Connect times are dreadful, related to DNS

Message 8 of 10
(4,240 Views)

Yes, the ipv6 protocol is enabled (presumably) by default in Vista. But my question pertains to the ipconfig results, specifically, how did the DNS address "suddenly" have ipv6?

 

Result from 17:13 shows:

DNS Servers . . . . . . . . . . . : 208.67.222.222
                                       208.67.220.220

 

Result from 19:54 shows:

DNS Servers . . . . . . . . . . . : 2001:558:feed::1
                                       2001:558:feed::2
                                       208.67.222.222
                                       208.67.220.220

 

During that time, I was on popcap for an hour, til about 18:30, and then the computer sat idle until 19:54. I am pretty sure I didn't have a browser open, and I know there's auto updates and virus protect that check the internet periodically. My router sits atop the tv cabinet, and I noticed that the wireless and internet lights were flashing, which is why I returned to the pc, to see what was what.

 

Thanks again, PJL.

amrsos
Copper Contributor
Copper Contributor
Posts: 6
Registered: ‎02-15-2014

Re: Connect times are dreadful, related to DNS

Message 9 of 10
(4,222 Views)

I found out why that is happening (suddenly having an IPv6 address for DNS). If I disconnect/connect through Network and Sharing center the wireless network connection gets and IPv6 DNS address. When it connects during system start/restart it does not.

 

Thank you both for your help and guidance. I will mark the "disable IPv6" as the answer, since that should always work.

msel
Contributor
Contributor
Posts: 1
Registered: ‎02-19-2014

Re: Connect times are dreadful, related to DNS

Message 10 of 10
(4,116 Views)

I am forced to wonder why you're getting assigned Comcast DNS servers (2001:558:feed::1 and 2001:558:feed::2).  Sounds like you have a wireless router that's offering you bad data.

 

I would probably also disable the IPv6 tunneling protocols, if they're enabled on your box:

 

netsh interface ipv6 teredo set state disabled

netsh interface ipv6 isatap set state disabled

netsh interface ipv6 6to4 set state disabled

 

How-To Videos
 
The following videos were produced by users like you!
   
Videos are subject to the Verizon Fios Community Terms of Service and User Guidelines and contains content that is not created by Verizon.
Have a spare Fios-G1100?Learn how to bridge it into your network
Get Started


Covid19

Browse Categories
Categories:
Posts

Verizon Troubleshooters
Unable to find your answer here? Try searching Verizon Troubleshooters for more options.
Modal Dialogue Title